Author Topic: Conflict with file vma.php  (Read 428 times)

thefbi

  • Jr. Member
  • **
  • Posts: 209
Conflict with file vma.php
« on: September 03, 2021, 08:55:41 am »
Hello,

I have a conflict with the JSN Uniform component. I can't open my forms in the component configuration, and at the top of the page I have 2 error messages:

Deprecated: Unparenthesized `a ? b : c ? d : e` is deprecated. Use either `(a ? b : c) ? d : e` or `a ? b : (c ? d : e)` in /PATH-TO-MY-SITE/administrator/components/com_virtuemart/helpers/vma.php on line 1491

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; VMAHelper has a deprecated constructor in /PATH-TO-MY-SITE/administrator/components/com_virtuemart/helpers/vma.php on line 17

What is strange is that on another website I have, with a recent installation of Virtuemart, I have no problem with JSN.

I also noticed that the file vma.php which causes problem is not present in the recent installation without problem...
But if I comment this file, nothing works anymore on the site.

Any idea ?

Joomla 3.10.1
VM 3.8.8 10472
PHP 7.4

AH

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3487
  • VirtueMart Version: 3.8.9
Re: Conflict with file vma.php
« Reply #1 on: September 03, 2021, 10:41:28 am »
vma.php is not a VM file
Regards
A

Joomla 3.9.27
php 7.4

thefbi

  • Jr. Member
  • **
  • Posts: 209
Re: Conflict with file vma.php
« Reply #2 on: September 03, 2021, 11:11:13 am »
Hello,

You are right!
I didn't see this, it's a VM Affiliate file, a component I tried to install... Well, I didn't, but anyway.

I'll see how to make order. Because if I delete it, my site won't work anymore, neither in frontend nor in backend.

thefbi

  • Jr. Member
  • **
  • Posts: 209
Re: Conflict with file vma.php
« Reply #3 on: September 03, 2021, 11:20:06 am »
It is OK now.
It remained a plugin of VM Affiliate component. I removed it and now it's OK.
Thanks AH!

AH

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3487
  • VirtueMart Version: 3.8.9
Re: Conflict with file vma.php
« Reply #4 on: September 03, 2021, 12:33:04 pm »
You are welcome - glad you managed to solve it  :)
Regards
A

Joomla 3.9.27
php 7.4