Author Topic: Category Page in Administrator Goes Blank  (Read 565 times)

act242

  • Beginner
  • *
  • Posts: 11
Category Page in Administrator Goes Blank
« on: February 19, 2021, 04:26:04 am »
I am getting the most frustrating error.

Everything in Virtuemart is working great - except for the category page in the admin area.  When I click on Product Categories, the page goes blank.  I have to hit refresh several times in order to get the page to display. 

I turned on the error reporting.  When I do get the category page it displays:

Message

1 vmdebug vmTime: time to load config: 0.00636506080627441
2 vmdebug vmTime: time to import plugins vmuserfield: 4.91142272949219E-5
3 vmdebug Start used Ram 20M
4 vmdebug isSuperVendor Active vendor 0 1
5 vmdebug vmTime: getChildCategoryList getChildCategoryListObject cached : 0.00996208190917969
6 vmdebug vmTime: getChildCategoryList getChildCategoryListObject cached 1: 0.00137495994567871
7 vmdebug vmTime: getChildCategoryList getChildCategoryListObject cached 2: 0.00124597549438477
8 vmdebug vmTime: "VirtueMartControllerCategory" Finished task category: 0.121381998062134
9 vmdebug End used Ram 22M
10 vmdebug Peak memory peak 22M

I have checked and optimized the database.  I have updated to the latest VM.  I am running PHP 7.4 with Joomla 3.9.24.

Any ideas?

Thanks!

-Reuel+

pinochico

  • 3rd party VirtueMart Developer
  • Full Member
  • *
  • Posts: 963
    • MiniJoomla
  • Skype Name: support-easysoftware
  • VirtueMart Version: 3
Re: Category Page in Administrator Goes Blank
« Reply #1 on: February 19, 2021, 06:19:34 am »
Find info how show error if you see blank page.

Definitelly is not turned on the error reporting in VM, but on joomla or server and see the log.

blank page is 500 error:
https://www.joomlashack.com/blog/joomla/white-screen-of-death/

then you can write your problem again there
www.minijoomla.org  - new portal for Joomla!, Virtuemart and other extensions
XML Easy Feeder - feeds from products, orders and database table
Virtuemart Email Manager - customs email templates

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28071
  • Always on vacation
    • Jenkin Hill Internet
Re: Category Page in Administrator Goes Blank
« Reply #2 on: February 19, 2021, 11:02:53 am »
Yes, most likely a 500 error. See our FAQ:  http://forum.virtuemart.net/index.php?topic=117042.0
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.9.10473 on Joomla 3.9.24 PHP 7.4.14

act242

  • Beginner
  • *
  • Posts: 11
Re: Category Page in Administrator Goes Blank
« Reply #3 on: February 19, 2021, 12:06:04 pm »
I installed the plugin that emails the fatal error.  I cannot use Joomla's debugging because nothing shows - just a blank screen,

Here is what I got: (I edited out some revealing paths)
Code: [Select]
RuposTel.com plg_system_fatal_catcher plugin detected a problem with your site.
Your site caused a blank screen upon a visit of this URL:

https://hallmarkrarecoins.com:443/administrator/index.php?option=com_virtuemart&view=category

Error message data:
1 Illegal length modifier specified 'f' in s[np]printf call in file: /xxx/xxx/public_html/libraries/src/Cache/Storage/FileStorage.php line: 346

timestamp: 2021-02-19T11:01:08+00:00

A Google search shows that this might be related to PHP 7.4.  I switched back to 7.3 - same issue. 

Thanks!

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28071
  • Always on vacation
    • Jenkin Hill Internet
Re: Category Page in Administrator Goes Blank
« Reply #4 on: February 19, 2021, 13:46:19 pm »
Previously I have seen a cache storage error with a site using JCH Optimise. This may not be the same, but removing JHC resolved the problem.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.9.10473 on Joomla 3.9.24 PHP 7.4.14

pinochico

  • 3rd party VirtueMart Developer
  • Full Member
  • *
  • Posts: 963
    • MiniJoomla
  • Skype Name: support-easysoftware
  • VirtueMart Version: 3
Re: Category Page in Administrator Goes Blank
« Reply #5 on: February 19, 2021, 13:53:28 pm »
Quote
cannot use Joomla's debugging because nothing shows - just a blank screen,

Really?
I wrote about Joomla debugging?
No, you don't read my post.

Joomla error maximum is onl y firts option.
If you see blank page still, then you must write to server and see error log on the server.

You trying?
www.minijoomla.org  - new portal for Joomla!, Virtuemart and other extensions
XML Easy Feeder - feeds from products, orders and database table
Virtuemart Email Manager - customs email templates

act242

  • Beginner
  • *
  • Posts: 11
Re: Category Page in Administrator Goes Blank
« Reply #6 on: February 19, 2021, 14:37:44 pm »
Thanks - I am trying.

act242

  • Beginner
  • *
  • Posts: 11
Re: Category Page in Administrator Goes Blank
« Reply #7 on: February 19, 2021, 14:38:32 pm »
I read about the JCH - it is disabled.

act242

  • Beginner
  • *
  • Posts: 11
Re: Category Page in Administrator Goes Blank
« Reply #8 on: February 19, 2021, 15:19:04 pm »
This is from the VM error log:

Code: [Select]
2021-02-19 12:29:02
ERROR vmError: Could not find product with id 3, entries exists for language? en-GB

Jörgen

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3350
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: Category Page in Administrator Goes Blank
« Reply #9 on: February 19, 2021, 15:21:46 pm »
Spend some time looking at product with id = 3, you have language issues, maybe could be this that breaks your page. Maybe not.

Delete product with id = 3 or edit accordingly.

Jörgen
Joomla 3.9.18
Virtuemart 3.4.x
Olympiantheme Hera (customized)
This reflects current status when viewing old post.

act242

  • Beginner
  • *
  • Posts: 11
Re: Category Page in Administrator Goes Blank
« Reply #10 on: February 19, 2021, 16:15:58 pm »
Jorgen -

Thanks.  There is no product #3 anywhere - and I looked throughout the database.  I have no idea where that is coming.  Where do I look for language issues?  I thought I had kept everything that same.

I am attaching the error log.

Jörgen

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3350
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: Category Page in Administrator Goes Blank
« Reply #11 on: February 19, 2021, 16:29:07 pm »
Check that you för not have some old entrance in a  product for patent product id. Clear this or if you have some leftover orphaned language strings for if 3 in database.
Jörgen
Joomla 3.9.18
Virtuemart 3.4.x
Olympiantheme Hera (customized)
This reflects current status when viewing old post.

pinochico

  • 3rd party VirtueMart Developer
  • Full Member
  • *
  • Posts: 963
    • MiniJoomla
  • Skype Name: support-easysoftware
  • VirtueMart Version: 3
Re: Category Page in Administrator Goes Blank
« Reply #12 on: February 19, 2021, 18:30:08 pm »
find ID3 in customfiled or related product and delete
www.minijoomla.org  - new portal for Joomla!, Virtuemart and other extensions
XML Easy Feeder - feeds from products, orders and database table
Virtuemart Email Manager - customs email templates

Jörgen

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3350
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: Category Page in Administrator Goes Blank
« Reply #13 on: February 19, 2021, 19:23:05 pm »
Nice, Rudolf, This has happened before.
Hope he fonds the issue.
Jörgen
Joomla 3.9.18
Virtuemart 3.4.x
Olympiantheme Hera (customized)
This reflects current status when viewing old post.

act242

  • Beginner
  • *
  • Posts: 11
Re: Category Page in Administrator Goes Blank
« Reply #14 on: February 19, 2021, 23:49:46 pm »
Getting  there, sorta.

I deleted the related fields in virtue_customs table (could you have hidden it any better!).

Went back to the admin, hit the categories menu selection - it worked.

Then I hit it again - blank page.

Refreshed three times - categories came up.

Hit it again - blank page.  Then refreshed three times.

??????