Author Topic: Add to Cart not working following Joomla Restore & Display issue  (Read 641 times)

conore

  • Beginner
  • *
  • Posts: 4
  • A beginner
Add to Cart not working following Joomla Restore & Display issue
« on: December 08, 2020, 18:11:39 pm »
Hi Guys

Apologies if this doesn't have all of the information you need, please let me know and I'll get it for you! I'm also not expecting a miracle, but if there are any ideas I can try that might pop into your head I would be more than grateful!

Basically - My companies webstore (extremely old) needed to be moved from its existing hosted server, onto a new one. Long story short: the company who hosted it is closing it down as we are no longer part of their group.

We use Joomla with VirtueMart installed for our webstore. To do the move, I downloaded the latest version of Akeeba Backup Pro (that would be accepted for my versions of PHP and Joomla), and completed a restore onto our new server using Akeeba Kickstart Pro. To my surprise- the restored site appeared to work, however when I went onto a product and tried to add it to cart, it would say that it has been added, but wouldnt actually add anything to the cart.

I then thought I might be able to fix this by logging into my administrator section, where I found the login would also not work. It didnt give any errors, it just cleared the username and password boxes.

Clearly something went wrong along the way, I just wanted to know whether anyone had any immediate ideas on what could be causing it? I wont pretend to be any kind of expert on websites or PHP so its all very confusing to me. I have managed IT for years now but have never needed to dabble to this depth.

My issue is fairly time sensitive, as the original server host will be turned off at the End of December, so any help you might be able to give would be massively appreciated.

The only thing I could think of is perhaps the SQL is not resolving queries correctly? - Again, not something I am expert in.

Please see versions below, as I said these are all super old (at a guess I would say last updated 2013 / 2014 - I have also explored the options of updating this before moving to new server and its not an option that is supported due to the age and configuration of the original host server)

My VirtueMart version is: 2.0.16
My Joomla version is: Joomla! 2.5.28 Stable [ Ember ] 10-December-2014
My PHP version is: 5.5.8
My New (temp) web address for store with issue: http://cluster1.website-staging.uk/has-store.co.uk/

Jörgen

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3225
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: Add to Cart not working following Joomla Restore
« Reply #1 on: December 09, 2020, 10:43:58 am »
If you have a working copy on your old server, mimic those settings and it should work on the new server. I would check if PHP version is to high. I would also make sure to use https, your new store uses only http, if the old one had https, settings in VM and joomla for https could break the code.

By the way, I can enter products in the cart on your new site.

Jörgen @ Kreativ Fotografi
Joomla 3.9.18
Virtuemart 3.4.x
Olympiantheme Hera (customized)
This reflects current status when viewing old post.

conore

  • Beginner
  • *
  • Posts: 4
  • A beginner
Re: Add to Cart not working following Joomla Restore
« Reply #2 on: December 18, 2020, 13:48:22 pm »
Thank you - it took a while but I managed to figure out how to take a more accurate backup of my old site and restore it in a better way.

I now have it working, but the cart is showing product pricing in red with a line through, as if they have been subject to some kind of deal, but the cart total doesn't change. Strange one. Next challenge! haha.

conore

  • Beginner
  • *
  • Posts: 4
  • A beginner
Cart showing prices in red and crossed out as standard?
« Reply #3 on: December 18, 2020, 14:01:37 pm »
Hi Guys,

I've recently completed a restore of my website to a new server, and after much difficulty I have finally managed to get it all working as expected.

One thing I have noticed though, is when a product is added to my cart, the item summary shows the price in red and crossed out (as you would expect to see when there has been a discount applied etc.). This is without any promotions applied and the cart total also does not change.

This doesn't affect the cart process, it just looks very strange!

I will attach a screenshot below.



I am assuming there has been something messed up during the restore - does anyone have any ideas?  :)

pinochico

  • 3rd party VirtueMart Developer
  • Full Member
  • *
  • Posts: 901
    • MiniJoomla
  • Skype Name: support-easysoftware
  • VirtueMart Version: 3
Re: Cart showing prices in red and crossed out as standard?
« Reply #4 on: December 18, 2020, 14:09:54 pm »
joomlart template override?
www.minijoomla.org  - new portal for Joomla!, Virtuemart and other extensions
XML Easy Feeder - feeds from products, orders and database table
Virtuemart Email Manager - customs email templates

conore

  • Beginner
  • *
  • Posts: 4
  • A beginner
Re: Cart showing prices in red and crossed out as standard?
« Reply #5 on: December 18, 2020, 14:17:03 pm »
I'm fairly novice when it comes to the terms - do I need to do an override or are you asking whether it has done one? :)

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28016
  • Always on vacation
    • Jenkin Hill Internet
Re: Add to Cart not working following Joomla Restore
« Reply #6 on: December 18, 2020, 15:08:00 pm »
The images show that you are not using the default VirtueMart templates for display - check the display using the Protostar template (actually I can't remember if Protostar was included in Joomla 2.5). If you have still got VM 2.0.16 and Joomla 2.5.28 then it would probably be best to update to current versus right now. Those old versions will not work with current versions of PHP.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.7 10374 on Joomla 3.9.24 PHP 7.4.12

pinochico

  • 3rd party VirtueMart Developer
  • Full Member
  • *
  • Posts: 901
    • MiniJoomla
  • Skype Name: support-easysoftware
  • VirtueMart Version: 3
Re: Add to Cart not working following Joomla Restore & Display issue
« Reply #7 on: December 18, 2020, 15:20:03 pm »
jenkinhill:
Quote
The images show that you are not using the default VirtueMart templates for display

Axactly as i wrote - Joomlart template override == price is red and crossed out
www.minijoomla.org  - new portal for Joomla!, Virtuemart and other extensions
XML Easy Feeder - feeds from products, orders and database table
Virtuemart Email Manager - customs email templates