Author Topic: Always Showing Products That Are Published But Not Featured On Main Storefront  (Read 216 times)

hornetts

  • Beginner
  • *
  • Posts: 4
  • A beginner
Hi,

Still learning the ropes here and using VirtueMart 3.8.4 10335.

I have 6 categories and 37 items. All items are being displayed on the main page of the storefront, even if they are published but NOT featured.

Obviously, I'd prefer to display only featured items on the main storefront page. For the remainder, I'd prefer that the customer clicks on the appropriate category.

I've tried playing with a few settings, but nothing seems to change how items are displayed.

I'd be grateful for some help. Clearly, I'm missing something.

Thanks.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27942
  • Always on vacation
    • Jenkin Hill Internet
The display is controlled in the Joomla menu link to the store on the VirtueMart category view settings tab.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.7 10374 on Joomla 3.9.23 PHP 7.4.12

hornetts

  • Beginner
  • *
  • Posts: 4
  • A beginner
Yup. It doesn't appear to be making any difference, despite the various things I've tried.

I am grateful for your help though! :-)

Jörgen

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3134
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
As Jenkins sais it is in VM Configuraration->Templates. Please select there Your own settings. If not enough watch out for any published modules.

This is what we can contribute with this small amount of information.

Jörgen
Joomla 3.9.18
Virtuemart 3.4.x
Olympiantheme Hera (customized)
This reflects current status when viewing old post.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27942
  • Always on vacation
    • Jenkin Hill Internet
If the menu configuration or VM Config/template settings don't help then maybe you are using a template with its own settings?

Otherwise more info is needed, such as a URL.....
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.7 10374 on Joomla 3.9.23 PHP 7.4.12