Author Topic: Upgrading from 3.6.10 to 3.8.2 got "No Reason Phrase"  (Read 680 times)

razor7

  • Jr. Member
  • **
  • Posts: 347
    • MGSCreativa - Professional VM!
Upgrading from 3.6.10 to 3.8.2 got "No Reason Phrase"
« on: August 29, 2020, 00:57:00 am »
Hi! today, in three different sites trying to upgrade from 3.6.10 to 3.8.2 I got an extrange error message No Reason Phrase see No Reason Phrase.png

To do the upgrade I drop the files in the joomla installer screen

Upgrading time take long, but it won't fail upgrading other extensions like SP Page Builder, Akeeba Pro, JCE Pro, RO CSVI and so on, all using joomla installer

After that no reason phrase error, VM page says it's 3.8.2 but I doubt that database upgrade took place, so I enable database tools and try to do a "Install/upgrade database tables" but I get 524 A timeout occurred (see screenshot)

My joomla version is 3.9.21 over Apache, PHP 7.3.21, linux, MySQL, etc
MGS Creativa - VirtueMart Payment Plugin Experts
http://www.mgscreativa.com

Take a look at our downloads section for VirtueMart payment plugins and mouch more!
http://www.mgscreativa.com/en/online-store

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3715
  • using Matomo instead of Google Analytics
Re: Upgrading from 3.6.10 to 3.8.2 got "No Reason Phrase"
« Reply #1 on: August 30, 2020, 21:19:39 pm »
Perhaps discuss the 524 error in the cloudflare community. Background Error 524 error indicates that Cloudflare made a successful TCP connection to the origin web server, but the origin did not reply with an HTTP response before the connection timed out. ... If the origin doesn't respond in that time, Cloudflare closes the connection and you'll see “Error 524: A timeout occurred”.

I remember one case where using php 7.2 or 7.3 instead of php 7.4 solved it. Maybe not all of your extensions/modules are happy with 7.4 (in case you do use it).
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations