Author Topic: error Class 'vmPSPlugin' not found  (Read 313 times)

hotrod

  • Jr. Member
  • **
  • Posts: 129
error Class 'vmPSPlugin' not found
« on: June 03, 2020, 13:19:35 pm »
Got this after running the latest update..  everything seems fine.. should I bee concerned ?
VirtueMart 3.6.10
Joomla! 3.9.18
PHP Version    PHP 7.3.13  
Dedicated Server.
http://forum.virtuemart.net/index.php?topic=124355.0

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27780
  • Always on vacation
    • Jenkin Hill Internet
Re: error Class 'vmPSPlugin' not found
« Reply #1 on: June 03, 2020, 13:43:05 pm »
I presume you mean an update to VirtueMart 3.8.2 10325 ? Have you also updated the AIO package?
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.8.4.10335 on Joomla 3.9.19 PHP 7.3.18

Jörgen

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2861
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: error Class 'vmPSPlugin' not found
« Reply #2 on: June 03, 2020, 13:44:20 pm »
If updating AIO doesn't help.

If I remember correctly this could be from a third party plugin not loading VM classes. I think You can find some threads about this.

Jörgen @ Kreativ Fotografi
Joomla 3.9.18
Virtuemart 3.4.x
Olympiantheme Hera (customized)

hotrod

  • Jr. Member
  • **
  • Posts: 129
Re: error Class 'vmPSPlugin' not found
« Reply #3 on: June 03, 2020, 14:00:01 pm »
Yea I ran both the updates in the backend.. like I said. site seems fine..  I'm a "new" to this keeping my sites updated.  :)   Is this an update I needed to run.  do you guys always update when they come out?  Iv'e always been afraid to..
VirtueMart 3.6.10
Joomla! 3.9.18
PHP Version    PHP 7.3.13  
Dedicated Server.
http://forum.virtuemart.net/index.php?topic=124355.0

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27780
  • Always on vacation
    • Jenkin Hill Internet
Re: error Class 'vmPSPlugin' not found
« Reply #4 on: June 03, 2020, 15:20:41 pm »
The latest VM version contains additional features, improvements and bug fixes - updates are usually released for a reason. The news item gives a list of changes  http://virtuemart.net/news/500-release-of-virtuemart-3-8-and-covid-support-campaign

A previous report of an error with vmPSPlugin mentioned a third party payment plugin needed updating, so if using payment or shipping plugins provided by third parties they may be worth checking for updates - or disable if not being used.

Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.8.4.10335 on Joomla 3.9.19 PHP 7.3.18

hotrod

  • Jr. Member
  • **
  • Posts: 129
Re: error Class 'vmPSPlugin' not found
« Reply #5 on: June 03, 2020, 15:29:57 pm »
Will do.. thank you!!
VirtueMart 3.6.10
Joomla! 3.9.18
PHP Version    PHP 7.3.13  
Dedicated Server.
http://forum.virtuemart.net/index.php?topic=124355.0

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10070
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: error Class 'vmPSPlugin' not found
« Reply #6 on: June 15, 2020, 10:36:22 am »
and the update is simple, just search at begin how they load the vm classes.

it should be just

Code: [Select]
if(!class_exists('VmConfig')) require(JPATH_ROOT .'/administrator/components/com_virtuemart/helpers/config.php');
if(class_exists('VmConfig')) VmConfig::loadConfig(false, false, false, false);
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/