Author Topic: package missing file vm-bs3-common.css  (Read 191 times)

fire47

  • Jr. Member
  • **
  • Posts: 90
package missing file vm-bs3-common.css
« on: March 25, 2020, 18:34:03 pm »
Where would I find "vm-bs3-common.css"? It is not in the download package nor is it showing in the repo.

http://dev.virtuemart.net/projects/virtuemart/repository/show/trunk/virtuemart/components/com_virtuemart/assets/css

fire47

  • Jr. Member
  • **
  • Posts: 90
Re: package missing file vm-bs3-common.css
« Reply #1 on: March 25, 2020, 18:39:57 pm »

StefanSTS

  • Global Moderator
  • Full Member
  • *
  • Posts: 534
  • VirtueMart Version: VM 4.2 on Joomla 4.5
Re: package missing file vm-bs3-common.css
« Reply #2 on: March 25, 2020, 19:19:19 pm »
Do you have a bootstrap 3 Template that need the setting in VirtueMart configuration?

I would suggest to set that setting back to default.

--
Stefan Schumacher
www.jooglies.com - VirtueMart Invoice Layouts

Please use only stable versions with even numbers for your live shop! Use Alpha versions only if you know what risk you are taking.

fire47

  • Jr. Member
  • **
  • Posts: 90
Re: package missing file vm-bs3-common.css
« Reply #3 on: March 25, 2020, 19:26:54 pm »
Do you have a bootstrap 3 Template that need the setting in VirtueMart configuration?

I would suggest to set that setting back to default.

Not sure what you mean. I've tried using Protostar template and it does the same thing. SOMETHING is calling for that CSS file.

StefanSTS

  • Global Moderator
  • Full Member
  • *
  • Posts: 534
  • VirtueMart Version: VM 4.2 on Joomla 4.5
Re: package missing file vm-bs3-common.css
« Reply #4 on: March 25, 2020, 19:31:48 pm »
There is a setting in VirtueMart config, tab 4.
It is called Layout Bootstrap version. Set that to None (Use Legacy).

The only setting that works properly because it's some beta stuff that should not be in there. At least in my humble opinion.

--
Stefan Schumacher
www.jooglies.com - VirtueMart Invoice Layouts

Please use only stable versions with even numbers for your live shop! Use Alpha versions only if you know what risk you are taking.

fire47

  • Jr. Member
  • **
  • Posts: 90
Re: package missing file vm-bs3-common.css
« Reply #5 on: March 25, 2020, 20:54:54 pm »
There is a setting in VirtueMart config, tab 4.
It is called Layout Bootstrap version. Set that to None (Use Legacy).

The only setting that works properly because it's some beta stuff that should not be in there. At least in my humble opinion.

So basically what you are saying is that VM only supports BS4, even though they have put in options for BS2 and BS3?

StefanSTS

  • Global Moderator
  • Full Member
  • *
  • Posts: 534
  • VirtueMart Version: VM 4.2 on Joomla 4.5
Re: package missing file vm-bs3-common.css
« Reply #6 on: March 26, 2020, 00:02:30 am »
What I am saying is that VirtueMart already supports BS2, BS3 and BS4 if the template supports it.

So if you keep everything on Legacy settings, the bootstrap layout settings do not mess with your template and everything works out.

The good working VM templates on BS2 or BS3 all work well if the setting is not touched.

I asked on some occasions to move that setting into the hidden config until this is properly done and tested, but it looks like the opinions are different.

Stefan
--
Stefan Schumacher
www.jooglies.com - VirtueMart Invoice Layouts

Please use only stable versions with even numbers for your live shop! Use Alpha versions only if you know what risk you are taking.