Author Topic: None of the products is in a category of the method ""  (Read 70 times)

Tikkiro

  • Jr. Member
  • **
  • Posts: 89
None of the products is in a category of the method ""
« on: February 12, 2020, 17:05:53 pm »
VirtueMart 3.6.10 10211
https://kitsandcards.co.uk/index.php/beaded-jewellery

I'm a intermediate user of VM having used it for the last 7-8 years but haven't really kept up with all the changes in different versions, and while it worked perfectly once, I've managed to get to a point where only certain aspects do (mostly the basic stuff like product creation etc).   However, this problem is more likely just my addled brain being too tired to figure out what the issue is.

I'm trying to set up appropriate shipping figures for a site which features varying product weights but having previously had lots of shipping options per weight, with endlless issues I've decided to just have two but even those aren't working properly for me.

SO one shipping amount should be for cards (but I'm not concerned about the multiple errors with those just now as I've yet to wade through them to edit weights etc) and another for jewellery items, and it's the latter I'm struggling to get sorted.  I've called the shipment method "jewellery" and weighted items accordingly so that any jewellery item should be charged a flat rate fee.  But I'm still getting the pesky "We are sorry, no shipment method matches the characteristics of your order." error msg for some undefinable reason.

Running debug gives this lot:

1 vmdebug 1 Language, default shoplanguage (VmConfig::$jDefLang): en_gb en-GB
2 vmdebug vmTime: time to load config: 0.0100231170654297
3 vmdebug Lädt die Config Var1:
en-GB
4 vmdebug There is no requested itemid loaded home Itemid Var1:
200001
5 vmdebug Router initialised with language en-GB
6 vmdebug vmTime: time to import plugins vmuserfield: 3.88622283935547E-5
7 vmdebug Start used Ram 2M
8 vmdebug SSL enabled
10 vmdebug unsetDefaults $defaults Var1:
11 vmdebug Defaults UNSET BT Var1:
12 vmdebug unsetDefaults $defaults Var1:
13 vmdebug Defaults UNSET ST Var1:
14 vmdebug my setupAddressFieldsForCart $countBT $this->byDefaultBT Var1:
15
Var2:
0
15 vmdebug Going to set pw fields unrequired
16 vmdebug getVendorId normal shopper
17 vmdebug My Memory Limit in Bytes 134217728
18 vmdebug None of the products is in a category of the method jewellery
19 vmdebug FOUND automatic SELECTED payment !! Var1:
1
20 vmdebug Doing base64_decode =���: S�9ܟO�7fo�*\�=p
21 vmdebug vmTime: Time consumed for shipment/payment plugins: 0.0208649635314941
22 vmdebug storeCart bindChecknStore executed
23 vmdebug My Url in loginform Var1:

index.php?option=com_virtuemart&view=cart&limitstart=0&keyword=&Itemid=26

24 vmdebug End used Ram 4M
25 vmdebug Peak memory peak 4M
26 vmdebug vmTime: "VirtuemartControllerCart" Finished task : 0.287036180496216

What does #18 mean - "None of the products is in a category of the method jewellery"  - what is the "method" it's talking about.   All the jewellery items are in one of 4 categories as shown on the display page.   I never had this kind of issue previously unless I'd put wrong weights in to the shipping methods, but I've double checked the jewellery one against the items I'm adding to the cart and really can't figure out the problem.

Plus now it keeps saying "Product removed" - for why??  I've tried checking & unchecking JS options without success.

I'm beyond tired grappling with it today and have searched Google & VM high and low for a fix, but everyone's situation is slightly different so I'm hoping someone here can wade through the confusion of my brain to bring some clarity to the problem.  Thanks :)

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 9374
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.6.8
Re: None of the products is in a category of the method ""
« Reply #1 on: February 12, 2020, 23:24:41 pm »
You need to post an image of your shipping setup

#18 is saying that none of the products in the cart are in the category set by your shipping method..

Are you filtering your shipping method by category?

GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation