Author Topic: multiple email for same order  (Read 799 times)

AH

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2943
  • VirtueMart Version: 3.6.0
Re: multiple email for same order
« Reply #15 on: September 05, 2019, 09:44:33 am »
That is not confirmed without further information. What logs/evidence do you have for your "conclusion".

Many many users have vm core paypal plugin working perfectly on php 7, 7.1 and 7.2

I expect you to find that it is a problem elsewhere.
regards
A

Joomla 3.9.8
php 7.1

guardiano78

  • Jr. Member
  • **
  • Posts: 259
    • C.S.S. Informatica
Re: multiple email for same order
« Reply #16 on: September 05, 2019, 15:14:14 pm »
Hello,
I simply downgraded the PHP server version from 7.3 to 5.6 ... from that moment on, i no longer received copies of e-mail for orders paid via PayPal plugin.
It's been over a week since I downgraded the PHP version, so I decided to report it in the forum.
Could it just be a coincidence? ...  I don't know.

Jörgen

  • Global Moderator
  • Full Member
  • *
  • Posts: 2316
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: multiple email for same order
« Reply #17 on: September 05, 2019, 18:58:16 pm »
I use PHP 7 since at least one year and can not see any of Your problems. You can have another plugin that interferes with the PayPal, sure that You do not have any other Payment plugin that is actvated but not used. ALL vmpayment plugin that are active are called by the triggers of one Payment even though they are not used. It is the responsibility of the other plugin not to interfere if the call is not meant for this specific plugin. This is common practice and also used in Joomla core for similar tasks. If You have a non used payment or similar plugin that is not PHP 7 ready it will create trouble even though You are not using it.

Jörgen @ Kreativ Fotografi
Joomla 3.9.8
Virtuemart 3.4.x
Olympiantheme Hera (customized)

AH

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2943
  • VirtueMart Version: 3.6.0
Re: multiple email for same order
« Reply #18 on: September 05, 2019, 20:21:06 pm »
That is useful information!

Not certain that VM is tested fully with php 7.3

I know I use php 7.2  with Paypal plugin and all is well
regards
A

Joomla 3.9.8
php 7.1