Author Topic: Virtuemart updating troubles. From 3.0.18 ro 3.4.2  (Read 166 times)

Grigorii

  • Beginner
  • *
  • Posts: 14
  • A beginner
Virtuemart updating troubles. From 3.0.18 ro 3.4.2
« on: June 11, 2019, 16:17:39 pm »
Dear support team!

We met some troubles after updating the VirtueMart

Before update we had:

- PHP 5.6.38 working in CGI mode
- Joomla 3.6.5
- VirtueMart 3.0.18
- RuposTel One Page Checkout 2.0.302.141115
- Akeeba Backup 6.1.1

The shop worked fine. Not very fast but normal.

First we have updated Joomla to 3.9.6 - good, no troubles.
After updating the VirtueMart to 3.4.2 we met the issue:

Fatal error: Call to undefined method Joomla\CMS\Component\Exception\MissingComponentException::get() in /var/www/magazini/data/www/new.magazin-integral.ru/templates/magazin-integral/error.php on line 57

Not for all products, about 10% of pages show the message.
And the pages are opening slower.

We tryied to change the PHP mode to 7.1 but got the message:
Fatal error: 'break' not in the 'loop' or 'switch' context in /var/www/magazini/data/www/new.magazin-integral.ru/components/com_onepage/overrides/vmplugin.php on line 1375

So what should we do in this case?


Jörgen

  • Global Moderator
  • Full Member
  • *
  • Posts: 2178
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: Virtuemart updating troubles. From 3.0.18 ro 3.4.2
« Reply #1 on: June 11, 2019, 18:55:22 pm »
Looks like you have problem with Your template, magazin-integral, the overrides are giving errors.

Jörgen @ Kreativ Fotografi
Joomla 3.9.8
Virtuemart 3.4.x
Olympiantheme Hera (customized)

Grigorii

  • Beginner
  • *
  • Posts: 14
  • A beginner
Re: Virtuemart updating troubles. From 3.0.18 ro 3.4.2
« Reply #2 on: June 11, 2019, 19:32:59 pm »
Dear Jörgen.

Thank you for advice. But a have no any overrides. I mean Extensions - Languages - Overrides. The list is empty.
Any other idea?

I changed the error.php file to default (from system folder) and it shows:

404 - Component not found.
You may not be able to visit this page because of:

an out-of-date bookmark/favourite
a search engine that has an out-of-date listing for this site
a mistyped address
you have no access to this page
The requested resource was not found.
An error has occurred while processing your request.
Please try one of the following pages:

Home Page
If difficulties persist, please contact the System Administrator of this site and report the error below.

Component not found.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27431
  • Always on vacation
    • Jenkin Hill Internet
Re: Virtuemart updating troubles. From 3.0.18 ro 3.4.2
« Reply #3 on: June 11, 2019, 23:11:33 pm »

Thank you for advice. But a have no any overrides. I mean Extensions - Languages - Overrides. The list is empty.


Template overrides will be in templates/[your Joomla template]/html/com_virtuemart/

Did you also update the Rupostel OPC?
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.8 PHP 7.0.33
Testing VM .3.6.0.10075 on Joomla 3.9.8

Jörgen

  • Global Moderator
  • Full Member
  • *
  • Posts: 2178
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: Virtuemart updating troubles. From 3.0.18 ro 3.4.2
« Reply #4 on: June 11, 2019, 23:29:21 pm »
Looks like you have problem with Your template, magazin-integral, the overrides are giving errors.

Jörgen @ Kreativ Fotografi

Please learn how to handle overrides in Joomla and contact Rupostel, who does this a bit differently:
Code: [Select]
/var/www/magazini/data/www/new.magazin-integral.ru/components/com_onepage/overrides/vmplugin.php
Jörgen
Joomla 3.9.8
Virtuemart 3.4.x
Olympiantheme Hera (customized)

Grigorii

  • Beginner
  • *
  • Posts: 14
  • A beginner
Re: Virtuemart updating troubles. From 3.0.18 ro 3.4.2
« Reply #5 on: June 12, 2019, 05:47:25 am »
Thanks to all for advices. Will try to fix with OPC!