Author Topic: VM Admin 40+ second product edit load with JCE Editor  (Read 397 times)

stresskills

  • Beginner
  • *
  • Posts: 23
    • My work from HB
VM Admin 40+ second product edit load with JCE Editor
« on: June 04, 2019, 21:15:18 pm »
VirtueMart 3.4.2
Joomla    3.9.2
JCE Editor 2.7.13

I'm having really bad load times for certain products and I tracked it down to products with multiple text area custom fields.
The load times can be over 60 seconds in some cases.

Any suggestions or help is appreciated.
When I set the editor to "no editor" in Joomla! global configuration the load times to edit the product are lightning fast.
"If you think you can do a thing or think you can't do a thing, you're right." Henry Ford

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 4067
  • Joomla & Virtuemart developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3
Re: VM Admin 40+ second product edit load with JCE Editor
« Reply #1 on: June 04, 2019, 21:44:37 pm »
Does the
Quote
multiple text area
use the JCE Editor ?

stresskills

  • Beginner
  • *
  • Posts: 23
    • My work from HB
Re: VM Admin 40+ second product edit load with JCE Editor
« Reply #2 on: June 04, 2019, 22:42:53 pm »
Yes, they do.
I have attached 2 screenshots.
For some reason on the slow loads product categories take a long time to load.

The 2nd screenshot shows the custom fields.
@Studio 42- on a side note- at the bottom of the screenshot you will notice your bulk image upload which I love!
"If you think you can do a thing or think you can't do a thing, you're right." Henry Ford

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 4067
  • Joomla & Virtuemart developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3
Re: VM Admin 40+ second product edit load with JCE Editor
« Reply #3 on: June 04, 2019, 23:00:25 pm »
JCE is a very heavy editor and it load full instance per textarea. It's why i dont used it in my plugins but the lightweight summernote editor.
About the category tree problem, if it never load, then its because you display PHP errors and json response is not valid, if you have an extra string(your error message).
Check in the browser console(F12 on PC) the XHR tab, if you dont see any PHP notice or error.
To know if your category loading problem is about a PHP error. Set Joomla config error reporting to "none" to see if it help.