Author Topic: Virtuemart and joomla 4  (Read 25527 times)

pinochico

  • 3rd party VirtueMart Developer
  • Full Member
  • *
  • Posts: 1242
    • MiniJoomla
  • Skype Name: support-easysoftware
  • VirtueMart Version: 3
Re: Virtuemart and joomla 4
« Reply #60 on: September 21, 2021, 08:12:00 am »
Quote
I haven't had already mentioned issues on a clean install (PHP7.4, J4.02 and 4.03, VM3.8.9.10534), but the front end is a bit broken, specifically custom fields (screenshot attached).

You have to wait for new version com_virtuemart.3.8.9.10542 or com_virtuemart.3.8.9.10543 or you can install every upgrade from activity.
www.minijoomla.org  - new portal for Joomla!, Virtuemart and other extensions
XML Easy Feeder - feeds from products, orders and database table
Virtuemart Email Manager - customs email templates

micropalla

  • Beginner
  • *
  • Posts: 49
Re: Virtuemart and joomla 4
« Reply #61 on: September 30, 2021, 20:40:44 pm »
So 3.8.9.10544 is ok with J4?
Can we use it?

pinochico

  • 3rd party VirtueMart Developer
  • Full Member
  • *
  • Posts: 1242
    • MiniJoomla
  • Skype Name: support-easysoftware
  • VirtueMart Version: 3
Re: Virtuemart and joomla 4
« Reply #62 on: October 01, 2021, 12:14:35 pm »
Quote
So 3.8.9.10544 is ok with J4?
Can we use it?

????
Sorry, try self, Im not your servant (modified by mod).
www.minijoomla.org  - new portal for Joomla!, Virtuemart and other extensions
XML Easy Feeder - feeds from products, orders and database table
Virtuemart Email Manager - customs email templates

micropalla

  • Beginner
  • *
  • Posts: 49
Re: Virtuemart and joomla 4
« Reply #63 on: October 05, 2021, 18:26:01 pm »
Well, I was not asking specifically to you but thanks anyway for your kind answer.

AH

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3491
  • VirtueMart Version: 3.8.9
Re: Virtuemart and joomla 4
« Reply #64 on: October 05, 2021, 19:08:02 pm »
There is now a test version out - not for live sites but worth looking at
Regards
A

Joomla 3.9.27
php 7.4

starexhaust

  • Beginner
  • *
  • Posts: 8
  • A beginner
Re: Virtuemart and joomla 4
« Reply #65 on: October 28, 2021, 13:24:46 pm »
I have been having issues with Virtuemart ever since I (preemptively) updated to J4.
VM still "works" on my site but it is definitely broken and I can't access the backend of it without getting error codes. I try to install every new version of VM that comes out to see if it fixes the issue but I get error codes like the ones attached. Please any help would be awesome.

Jörgen

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3731
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: Virtuemart and joomla 4
« Reply #66 on: October 28, 2021, 13:52:48 pm »
The VM versions that are mentioned here (3.8.9) are release canditates and not stable versions. There are still some issues with VM together with Joomla 4 that have not been solved.
You are pretty much on your own right now if You have already upgraded to Joomla 4 on a production site. These VM versions are not stable versions and not for production sites.
They are available for users that are willing to contribute in testing the software before stable release.

Jörgen @ Kreativ Fotografi
Joomla 3.9.18
Virtuemart 3.4.x
Olympiantheme Hera (customized)
This reflects current status when viewing old post.

starexhaust

  • Beginner
  • *
  • Posts: 8
  • A beginner
Re: Virtuemart and joomla 4
« Reply #67 on: October 28, 2021, 14:18:35 pm »
Okay I will hold off for now, hope a stable version comes soon, thanks.