Author Topic: Virtuemart and joomla 4  (Read 2093 times)

Eagle21

  • Beginner
  • *
  • Posts: 1
  • A beginner
Virtuemart and joomla 4
« on: May 10, 2019, 19:51:28 pm »
Hello
I am new in virtuemart and i plan to make an eshop with that,and i would like to ask you about the compatibility with the neww joomla 4.Will be combatible or not?

Jörgen

  • Global Moderator
  • Full Member
  • *
  • Posts: 2319
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: Virtuemart and joomla 4
« Reply #1 on: May 10, 2019, 22:27:27 pm »
Yes

Jörgen @ Kreativ Fotografi
Joomla 3.9.8
Virtuemart 3.4.x
Olympiantheme Hera (customized)

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9919
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Virtuemart and joomla 4
« Reply #2 on: May 13, 2019, 17:30:55 pm »
But not now and not for the Joomla 4 Alpha. We will start with development for joomla 4, when they announce the first RC (release candidate), or maybe in the late beta phase.

Remember, Joomla 3 will still be supported for another 2 years after Joomla 4 gets released. Our priority is a stable system, so we will take our time to make everything working properly. Don't expect a VM version for Joomla 4 the day it is released.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27502
  • Always on vacation
    • Jenkin Hill Internet
Re: Virtuemart and joomla 4
« Reply #3 on: May 13, 2019, 23:55:52 pm »
And don't expect Joomla 4 to be bug-free the day it is released.  Serious Joomla users will wait for the first two update releases at least before risking live sites on J4.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.6.1.10121 on Joomla 3.9.11 PHP 7.0.33
Testing 3.6.1.10129 on Joomla 3.9.11

balai

  • 3rd party VirtueMart Developer
  • Full Member
  • *
  • Posts: 1375
Re: Virtuemart and joomla 4
« Reply #4 on: May 15, 2019, 12:17:06 pm »
Max maybe you could come with an alpha or a beta along with J4 stable release.

It is a great opportunity to gain market share, exploiting others lagging or incompatibility with the new system.
I see the J4 as an opportunity to re-invent my business and expand my client base.

Just my thoughts.