Author Topic: Paypal Standard payment method stuck in Sandbox mode  (Read 286 times)

Tryer

  • Jr. Member
  • **
  • Posts: 68
Paypal Standard payment method stuck in Sandbox mode
« on: April 19, 2019, 18:02:42 pm »
I am using VM v3.4.2 in a new Joomla 3.9.5 site with PHP 7.2.17.
I have been using the Paypal sandbox to test the shop setup but find that I now cannot escape from Sandbox mode.
I have three payment methods:
Credit/Debit card
Direct Bank transfer
Paypal Standard

Credit/Debit card payments are made using the Paypal service and is currently set to production mode witha merchant email declared. However, the direct Paypal payments setup is stuck in Sandbox. When I select production mode and save, the screen does not change to include a window for a merchant email etc.

Am I doing something wrong or is there a problem? I have read lots of posts regarding similar issues but most are for previous versions back in 2014 etc. The change to the paypal.xml file suggested as a fix at that time is not now necessary as my paypal.xml file is aalready as the previous fix suggested.

Any comments appreciated.

StefanSTS

  • Global Moderator
  • Jr. Member
  • *
  • Posts: 276
  • VirtueMart Version: VM 4.2 on Joomla 4.5
Re: Paypal Standard payment method stuck in Sandbox mode
« Reply #1 on: April 22, 2019, 11:29:28 am »
Hi,

since you haven't got an answer yet, I guess you have to be more specific with your plugin selection.
Maybe some screenshots of your single payment settings per plugin.

Which Paypal plugin do you use?
If you use two different Paypal plugins from different third parties, there might be a problem that one plugin catches the events of the other.

Stefan
--
Stefan Schumacher
www.jooglies.com - VirtueMart Invoice Layouts

Tryer

  • Jr. Member
  • **
  • Posts: 68
Re: Paypal Standard payment method stuck in Sandbox mode
« Reply #2 on: April 22, 2019, 17:36:29 pm »
Thanks for your reply. I have just resolved the problem by deleting the payment method using the Sandbox and recreating a new Paypal payment method from scratch. I don't understand what was wrong, because it looks just like the one I deleted, but I seem to have got around the problem.
Thanks anyway for your response.