Author Topic: Ask a Question/reCAPTCHA error message upon submission - 0-invalid - keys  (Read 837 times)

bmw2182

  • Jr. Member
  • **
  • Posts: 91
Running Joomla 3.9.3 and virtuemart 3.4.2
Added reCAPTCHA to Ask a question.  It shows up at the bottom like I would expect and once I prove I'm not a robot and click to submit it goes to another screen and I get 0-invalid keys.  I have attached a screen shot of the error I'm getting.

I have verified that Site key and Secret key are correct in google.  Do I have to setup a callback in Google to redirect it once it is submitted?

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27431
  • Always on vacation
    • Jenkin Hill Internet
Are you using the reCaptcha version 2 plugin with Version 2 credentials?
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.8 PHP 7.0.33
Testing VM .3.6.0.10075 on Joomla 3.9.8

bmw2182

  • Jr. Member
  • **
  • Posts: 91
Yes, I am using the reCaptcha version 2 plugin.  I'm not clear on what you mean for Version 2 credentials - I have selected version 2 when setting it up on google.

ThiloS

  • Beginner
  • *
  • Posts: 7
  • A beginner
same problem here!

ReCaptcha V2 (normal "i am not a robot" - not invisible).

error: 0 - invalid-keys


jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27431
  • Always on vacation
    • Jenkin Hill Internet
error: 0 - invalid-keys generally means that the wrong public/secret keys are used in the plugin config.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.8 PHP 7.0.33
Testing VM .3.6.0.10075 on Joomla 3.9.8

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 3846
  • Joomla & Virtuemart developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3
see https://www.google.com/recaptcha/admin/ ifyou have the right key installed

testy

  • Beginner
  • *
  • Posts: 7
  • A beginner
Same problem here. I've installed all updates and in three different Google-accounts I've created keys "V2 checkbox-keys". None of them work.

Jörgen

  • Global Moderator
  • Full Member
  • *
  • Posts: 2179
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Joomla 3.9.8
Virtuemart 3.4.x
Olympiantheme Hera (customized)

testy

  • Beginner
  • *
  • Posts: 7
  • A beginner
Thank you for the link Jörgen. The instructions don't work for Virtuemart. The Default Captcha is set to Invisible. Virtuemart uses the normal captcha, as mentioned on https://forum.virtuemart.net/index.php?topic=140813.0 . I disabled the normal captcha and got a new error there was no captcha available. So Virtuemart doesn't look at the default captcha.

testy

  • Beginner
  • *
  • Posts: 7
  • A beginner
A first test looks like the plugin "System - Page cache" is conflicting with the captcha. Disabling the plugin solved the problem for now.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9843
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
For the old recaptcha or the new invisible one?
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

bmw2182

  • Jr. Member
  • **
  • Posts: 91
I'm not sure why, but everything is working great now!