Author Topic: What is the reason of $VMLANG NOT SET in the com_virtuemart.log.php?  (Read 372 times)


  • Jr. Member
  • **
  • Posts: 66

I'm looking in the com_virtuemart.log.php file and there do I see this errors:

Code: [Select]
2019-01-04 22:10:31 ERROR vmError: $vmlang not set
2019-01-04 22:10:31 $VMLANG NOT SET <pre>#0  vmTrace() called at [/..../com_virtuemart/helpers/vmtable.php:202]
#1  VmTable::getInstance() called at [/..../com_virtuemart/helpers/vmmodel.php:432]
#2  VmModel->_createTable() called at [/...../com_virtuemart/helpers/vmmodel.php:394]
#3  VmModel->getTable() called at [/...../com_virtuemart/helpers/vmmodel.php:600]
#4  VmModel->setMainTable() called at [ /....

I've been looking at the configuration, but there I have configured the language:

  • Shop language: Dutch (nl-NL)
  • Multilingual shop: Dutch (nl-NL)
  • No Fallback: not selected
  • Custom Fallback: (en-EN)

Should I have to configure something were I'm not aware of?
Or I'm realizing myself now when I'm writing this, it is not a multilingual shop, it is only dutch, should I leave this blanc? Could that be the reason
Or I've seen that some things are not tranlated, so you will see the directive. Could that be the reason, so that I have to find out which one it is and make an override for it?
Or what else is left that I'm not aware of?




  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3447
  • using Matomo instead of Google Analytics
Re: What is the reason of $VMLANG NOT SET in the com_virtuemart.log.php?
« Reply #1 on: January 07, 2019, 19:40:54 pm »
Seems to be similar to this:

I you want to use Dutch only in the Joomla and VirtueMart frontends and backends, I would try the following language settings:

Use english as fallback for untranslated strings: selected
Multilingual shop : leave blank
Custom Fallback: leave blank
No Fallback: not selected

> Save the configuration.

Also, check in your database using phpmyadmin, if your product data are saved in the nl-NL tables an not in en-GB tables.
Non-English Shops: Are your language files up to date?