Author Topic: Why am I not getting emails sent when someone asks a Question from VM  (Read 659 times)

Newbie74

  • Beginner
  • *
  • Posts: 5
  • A medium beginner
Hello all

I am trying to figure out why i do not get an email sent when someone "Asks a question about this product" from the product screen?

I have been pulling my hair out over this one  :-\  :-[

Thank you for any help here.

Quirky ¿
Words are the magic that push dreams into being.

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3533
  • using Matomo instead of Google Analytics
Re: Why am I not getting emails sent when someone asks a Question from VM
« Reply #1 on: January 03, 2019, 10:20:40 am »
VirtueMart uses the email configuration of Joomla. In the Joomla 'Global Configuration' > 'Server' tab, you can click the 'Send Test Mail' button below the mail settings. Does that work? Usually selecting the SMTP mailer is the best choice.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 9186
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.4.2
Re: Why am I not getting emails sent when someone asks a Question from VM
« Reply #2 on: January 03, 2019, 11:55:11 am »
as jjk says .. it is a simple email using the configured Joomla mailer..

so do the basic checks, spam, does it work from the contact page, the test mailer, the VM order emails etc etc
put full debugging on to chk for errors, search any logs for problems

GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

kontetinto

  • Beginner
  • *
  • Posts: 1
  • A beginner
Re: Why am I not getting emails sent when someone asks a Question from VM
« Reply #3 on: January 04, 2019, 15:00:17 pm »
i had similar issue, thank you for answer

Newbie74

  • Beginner
  • *
  • Posts: 5
  • A medium beginner
Re: Why am I not getting emails sent when someone asks a Question from VM
« Reply #4 on: January 19, 2019, 01:35:38 am »
Thank you all.

I am still not getting the email but I do get an email if someone send me a message via the contact form or places an order...

Any other ideas?

Thank you again.
Words are the magic that push dreams into being.

Jörgen

  • Global Moderator
  • Full Member
  • *
  • Posts: 2422
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: Why am I not getting emails sent when someone asks a Question from VM
« Reply #5 on: January 19, 2019, 19:40:37 pm »
VM version ?
Joomla version ?
Recaptcha ?

Custom template, try with Protostar ?

Jörgen @ Kreativ Fotografi
Joomla 3.9.8
Virtuemart 3.4.x
Olympiantheme Hera (customized)