Author Topic: update 3.2.12 to 3.2.14 fails "use MySQLi" but site is using MySQLi ?!  (Read 184 times)

carsten888

  • Jr. Member
  • **
  • Posts: 222
    • pages-and-items.com
I'm trying to update my live site from 3.2.12 to 3.2.14.
I get this warning:
Quote
To ensure seemless working with Virtuemart please use MySQLi as database type in Joomla configuration
Extension Update: Custom install routine failure.
But in the joomla config the database IS using mysqli.

How to proceed?

I got an exact copy of the site on localhost and had no problem doing the update.   :o

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27149
  • Always on vacation
    • Jenkin Hill Internet
Re: update 3.2.12 to 3.2.14 fails "use MySQLi" but site is using MySQLi ?!
« Reply #1 on: December 31, 2018, 11:59:57 am »
PHP version?
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.9989 on Joomla 3.9.1 PHP 7.0.32
Testing VM 3.4.3.9993 on Joomla 3.9.1

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8678
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.14
Re: update 3.2.12 to 3.2.14 fails "use MySQLi" but site is using MySQLi ?!
« Reply #2 on: December 31, 2018, 12:36:09 pm »
and why 3.2.14?
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

carsten888

  • Jr. Member
  • **
  • Posts: 222
    • pages-and-items.com
Re: update 3.2.12 to 3.2.14 fails "use MySQLi" but site is using MySQLi ?!
« Reply #3 on: December 31, 2018, 14:19:41 pm »
php 7.1.25-1
J 3.8.12
Quote
and why 3.2.14?
because that is the latest version according to Joomla update.
So I emptied the cache and tried again, now its version 3.4.2. But when trying to update I get the same error.


jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27149
  • Always on vacation
    • Jenkin Hill Internet
Re: update 3.2.12 to 3.2.14 fails "use MySQLi" but site is using MySQLi ?!
« Reply #4 on: December 31, 2018, 17:06:23 pm »
ISTR Milbo mentioned that the latest VM version is for Joomla 3.9  (now at 3.9.1)
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.9989 on Joomla 3.9.1 PHP 7.0.32
Testing VM 3.4.3.9993 on Joomla 3.9.1

carsten888

  • Jr. Member
  • **
  • Posts: 222
    • pages-and-items.com
Re: update 3.2.12 to 3.2.14 fails "use MySQLi" but site is using MySQLi ?!
« Reply #5 on: January 01, 2019, 16:43:24 pm »
I updated to 3.9.1 and tried again. Same issue.  :-[