Author Topic: Add to cart button not working in only one category  (Read 634 times)

melsonmarketing

  • Beginner
  • *
  • Posts: 37
Add to cart button not working in only one category
« on: March 21, 2019, 15:49:35 pm »
J3.9.4
VM 3.4.2
Php 7.2.15

Hi!

I'm a little bit helpless :-(

In a shop of a client (can't post address because it's a prt of an intranet) I have 42 categories with all in all 214 products.

In 41 categories everything works as expected. Only one category has the following problem:

Neither in category view, nor in productdetails view the cart button is working.

There are absolutely no deviant templatesettings. I switched template to beez and protostar - it's all the same problem.

Cleared all caches, switched Php-Version, disabled JCH Optimze etc. - no success.

This is an absolute mystery

Does anyone of you have an idea - maybe I'm complete blind :-(

Thanks for any tips or help


Jörgen

  • Global Moderator
  • Full Member
  • *
  • Posts: 2118
    • Kreativ Fotografi
  • VirtueMart Version: 3.2.12
Re: Add to cart button not working in only one category
« Reply #1 on: March 21, 2019, 19:29:14 pm »
Without an URL no.

Check Your settings.
How did You create them, first, last together with other, copied  etc

Jörgen @ Kreativ Fotografi
Joomla 3.9.1
Virtuemart 3.2.12
Olympiantheme Hera (customized)

melsonmarketing

  • Beginner
  • *
  • Posts: 37
Re: Add to cart button not working in only one category
« Reply #2 on: March 22, 2019, 14:14:46 pm »
Thanks anyhow.

The client was using an old template (still from J!2.5)

We built a new one and now everything is working.

Anyhow it is strange that only one cat was concerned...

melsonmarketing

  • Beginner
  • *
  • Posts: 37
Re: Add to cart button not working in only one category
« Reply #3 on: March 26, 2019, 14:12:14 pm »
***EDIT***03/26/19

I THOUGHT we had it and marked this as solved.
Returning to the site after the weekend the same problem appeared.

Only products in one single Category couldn't be added to the cart, while all categories and products are using the same templates.

This is absolutely strange - so I analyzed every single detail as custom fields, customer groups, manufacturer-settings, I've been though the database etc...

NOTHING!

Then I created a new category "Test" and a Product "Test1" - worked
Copying productdata from the corrupt to the testproduct - add to cart not working
Now I changed the title back to "Test1" - worked

The real Productname in this category is "Citalopram" (pharmaceutics), added with the dose within the title. (e.g. Citalopram 20 MG)
Reducing the Product title to "Citalop." or "Citalop. 20 MG" - guess what: IT WORKS!!!

And now the Jackpot:

I went to an other shop of an other client dealing with completely other things (horsefood).
Over there I created an article named "Citalopram" for testing-purposes.

Now what do you think happened?
Adding this product to the cart isn't possible.

Finally it's solved with a workaround (renaming the product) - but I think this mystery is worth to stay here?!

Would be interesting to hear if you could sell "Citalopram" (which is an antidepressant btw.)  :D


Regards
Michael

melsonmarketing

  • Beginner
  • *
  • Posts: 37
Re: Add to cart button not working in only one category
« Reply #4 on: April 01, 2019, 14:05:25 pm »
...and the beat goes on...

same system, same problem.

"SPAM" can't be added to cart. Using SPAM as prductname the add to cart function is blocked.

Replacing the "T" with the greek letter "Tau" it works.

As in both cases the phenomenon is related to pharmaceutical products (antidepressant and here opioid pain medication), I ask myself, if a kind of filter is working in the background...

This would be fatal, because the system is working within the intarnet of a pharmacy association.

Hope someone has an idea about this

Jörgen

  • Global Moderator
  • Full Member
  • *
  • Posts: 2118
    • Kreativ Fotografi
  • VirtueMart Version: 3.2.12
Re: Add to cart button not working in only one category
« Reply #5 on: April 01, 2019, 14:28:38 pm »
Perhaps using "default blacklist" in Joomla ?

Jörgen @ Kreativ Fotografi
Joomla 3.9.1
Virtuemart 3.2.12
Olympiantheme Hera (customized)

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27388
  • Always on vacation
    • Jenkin Hill Internet
Re: Add to cart button not working in only one category
« Reply #6 on: April 01, 2019, 15:19:10 pm »
Have you tried with different browsers?  Spam filtering on the host or "child settings"?  Check a copy of the site on localhost.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.6 PHP 7.0.33
Testing VM 3.4.5.10059 on Joomla 3.9.6

melsonmarketing

  • Beginner
  • *
  • Posts: 37
Re: Add to cart button not working in only one category
« Reply #7 on: April 08, 2019, 12:25:35 pm »
Thank you guys - I'm very busy at the moment.

I'll try your hints.

And: NO, it was not an apriljoke ;-)