Author Topic: Is Virtuemart 3.2.4 Compatibility with Joomla 3.8.2?  (Read 213 times)

MichaeljonesMJ

  • Beginner
  • *
  • Posts: 2
  • A beginner
Is Virtuemart 3.2.4 Compatibility with Joomla 3.8.2?
« on: December 06, 2018, 09:31:07 am »
Hello. I've been developing a e-commerce website using a Shape5 site shaper template (template setup with content) but it was based on the older 3.6.2 Joomla. I updated Joomla to 3.6.5 and I think I updated one of the Virtuemart plugins and it was fine.

Then I tried updating Joomla to 3.8.1 and it seems to have gotten rid of Virtuemart in my administration panels and menus which has taken away my ability to manage it. The plugins and component are still there however and it is still functioning on the front end of the website. I looked at the VM website which really lacks in info especially regards to anything past 3.7.x Joomla and their website lacks https certificates currently so I can't even download and reinstall VM. Anyone have experience running VM on 3.8.x Joomla. Problems?

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8678
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.14
Re: Is Virtuemart 3.2.4 Compatibility with Joomla 3.8.2?
« Reply #1 on: December 06, 2018, 10:13:04 am »
It will run fine .. 

all that has happened is the entries and VM admin module have been lost/unpublished

chk under J admin -> modules -> administration - look for VM - Administrator Module

make sure its published in the menu position

if not try reinstalling the VM AIO package
try reinstalling VM if the menu entries have disappeared for VM admin or search on here for the sql needed to remake them

http://dev.virtuemart.net/attachments/download/1143/com_virtuemart.3.4.2.9966.zip

http://dev.virtuemart.net/attachments/download/1144/com_virtuemart.3.4.2.9966_package_or_extract.zip
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27149
  • Always on vacation
    • Jenkin Hill Internet
Re: Is Virtuemart 3.2.4 Compatibility with Joomla 3.8.2?
« Reply #2 on: December 06, 2018, 11:08:08 am »
And to answer the question about VM on J3.8.x, there are no issues, and no issues either with the current Joomla version, 3.9.1`
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.9989 on Joomla 3.9.1 PHP 7.0.32
Testing VM 3.4.3.9993 on Joomla 3.9.1