Author Topic: Upgrade prompt  (Read 973 times)

Teejay

  • Beginner
  • *
  • Posts: 31
    • Altenagala atelier
  • VirtueMart Version: VM 3.012
Upgrade prompt
« on: November 12, 2018, 22:13:22 pm »
I run a Joomla 3.8.13 with VM3.4.2, am prompted to upgrade my VM administrator to the latest version, problem is, after performing this, still get same prompt, how can i adjust this

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27211
  • Always on vacation
    • Jenkin Hill Internet
Re: Upgrade prompt
« Reply #1 on: November 12, 2018, 23:17:16 pm »
Are you sure you arer not getting a prompt to upgrade Joomla to the latest version, 3.9 ?
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.9989 on Joomla 3.9.2 PHP 7.0.33
Testing VM 3.4.3.10014 on Joomla 3.9.2

Teejay

  • Beginner
  • *
  • Posts: 31
    • Altenagala atelier
  • VirtueMart Version: VM 3.012
Re: Upgrade prompt
« Reply #2 on: November 13, 2018, 10:04:32 am »
Am constantly being prompted to update VM administrator part, from VM3.4.1 to the latest version of VM3.4.2, am currently running on J3.8.13, i however tried upgrading Joomla 3.9.0, with no success, am getting error 500 in the backend, with blank website, my database is also warning, some issue with column session, session_id is got wrong attributes for varbinary (192), but am seeing VARCHAR (191)in this role, so maybe u can educated me on this

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8732
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.14
Re: Upgrade prompt
« Reply #3 on: November 13, 2018, 10:54:27 am »
Quote
am getting error 500 in the backend

you need to find this error and fix - see Faqs WSOD

I have noticed that the J3.9 update takes significantly longer than previous ones and I had to raise the server timeout limit on some of my accounts
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

Teejay

  • Beginner
  • *
  • Posts: 31
    • Altenagala atelier
  • VirtueMart Version: VM 3.012
Re: Upgrade prompt
« Reply #4 on: November 15, 2018, 09:52:42 am »
Okay, do i need consult my server for this, or adjust it in the php setting, problem is could not identify the server time out, adjust maximum upload en post limit though, looking forward to your response

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8732
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.14
Re: Upgrade prompt
« Reply #5 on: November 15, 2018, 11:25:30 am »
Depends on your host-- on my server I can set all these params via my cPanel..
but first u have to find the 500 error...

All errors log "somewhere"

GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

Teejay

  • Beginner
  • *
  • Posts: 31
    • Altenagala atelier
  • VirtueMart Version: VM 3.012
Re: Upgrade prompt
« Reply #6 on: November 15, 2018, 13:19:42 pm »
Okay, i have increased it from 30sec to 360sec, is this sufficient? i got the error 500, when i tried twice upgrading to J3.9.0, i have since reverted to J3.8.13, a backup, now my Joomla global configuration panel is not working, and getting prompted to fix my database, something to do with wrong attribute with session column, session_id, Varbinary (192), i have not tried upgrading since, trying to fix the database issue first, appreciate your input

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8732
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.14
Re: Upgrade prompt
« Reply #7 on: November 15, 2018, 19:11:43 pm »
These are Joomla / your site / host problems -- this is a VM forum -- please direct your questions to the Joomla forum
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

Teejay

  • Beginner
  • *
  • Posts: 31
    • Altenagala atelier
  • VirtueMart Version: VM 3.012
Re: Upgrade prompt
« Reply #8 on: November 15, 2018, 22:49:34 pm »
How is updating VM3.4.1 a Joomla problem?i get continues prompt to update to VM 3.4.2, after each click to update, it goes update successful, when i navigate away, get prompted to upgrade again, meanwhile in the control panel, i see VM3.4.2, it's that a joomla issue

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8732
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.14
Re: Upgrade prompt
« Reply #9 on: November 15, 2018, 23:01:13 pm »
Quote
i got the error 500, when i tried twice upgrading to J3.9.0, i have since reverted to J3.8.13

re VM - why don't u just download the install pack and install?
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27211
  • Always on vacation
    • Jenkin Hill Internet
Re: Upgrade prompt
« Reply #10 on: November 16, 2018, 11:29:12 am »
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.9989 on Joomla 3.9.2 PHP 7.0.33
Testing VM 3.4.3.10014 on Joomla 3.9.2

Teejay

  • Beginner
  • *
  • Posts: 31
    • Altenagala atelier
  • VirtueMart Version: VM 3.012
Re: Upgrade prompt
« Reply #11 on: November 16, 2018, 12:02:47 pm »
http://forum.virtuemart.net/index.php?topic=123808
Don't understand your comment, i did mention that i run a J3.8.13 with VM 3.4.2, problem is continuous  update prompt for administrator component VM3.4.1, despite upload of VM 3.4.2 aio, still getting this, should i uninstall this VM 3.4.1 in extension, or is this a script issue 

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8732
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.14
Re: Upgrade prompt
« Reply #12 on: November 16, 2018, 12:22:35 pm »
if your Joomla won't update either why do u not think u have a general server permissions or config problem?

If it looks like a cat and smells like a cat I call it a cat....
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

Teejay

  • Beginner
  • *
  • Posts: 31
    • Altenagala atelier
  • VirtueMart Version: VM 3.012
Re: Upgrade prompt
« Reply #13 on: November 17, 2018, 11:37:40 am »
how is this helpful? obviously there is something wrong somewhere, so how do i check for this? the server permission issue, you might be right about the configuration, cos my other Joomla site upgrated successfully, with VM 3.4.2 component, on same server, u reckon it might be in VM config? some dude sent me a private message claiming to have a fix, for a fee, probably a bug in the script, meanwhile i will get in touch with my server,

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8732
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.14
Re: Upgrade prompt
« Reply #14 on: November 17, 2018, 13:18:39 pm »
It is helpful because IMHO there is a general problem on your server concerning updating

if u say Joomla and VM will not update then this points obviously not to a VM problem but a general server/Joomla problem
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation