Author Topic: Product category issues post virtuemart upgrade  (Read 1308 times)

ufo_hk

  • Jr. Member
  • **
  • Posts: 79
    • 4success Ltd
Product category issues post virtuemart upgrade
« on: November 12, 2018, 00:31:45 am »
Hi,

Site: www.firstmoments.co.nz
joomla: 3.9.0
Virtuemart: 3.4.2
php: 7.1.6

Recently upgraded this site (joomla and virtuemart) and am now experiencing problems with assigning categories to new products or changing the category of an existing product.

The "Product Categories" list shows only the option: Do Not Store

While the "Force canonical category" shows the full list of categories.

When I add a new category to the Product Categories - it adds it to the "Force canonical category" list. ??

When I create a new product from scratch or via clone and I save the product I get an error msg: 1062 Duplicate entry '99-0' for key 'virtuemart_product_id'

The product is saved - however the "Product Category" column has "CanonCat:" in it for that product.

Things I have tried:
Clear caches and different browsers - no change.
Enabled Debug mode - but don't see any messages which seem relevant.

Any assistance in sorting this issue will be appreciated.
Thanks

hellorain

  • Jr. Member
  • **
  • Posts: 114
    • Raincreatives - Virtuemart & Mobile Commerce Experts
  • Skype Name: raincreatives
Re: Product category issues post virtuemart upgrade
« Reply #1 on: November 13, 2018, 07:06:20 am »
Hello,

i can help you!!


Best Regards,
hellorain.
Raincreatives - Virtuemart & Mobile Commerce Experts

chrisb_

  • Beginner
  • *
  • Posts: 3
  • A beginner
Re: Product category issues post virtuemart upgrade
« Reply #2 on: November 29, 2018, 22:49:32 pm »
Hello,
I have exactly the same problem. Is there any solution yet?

Thanks

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27480
  • Always on vacation
    • Jenkin Hill Internet
Re: Product category issues post virtuemart upgrade
« Reply #3 on: November 29, 2018, 23:15:01 pm »
Have you tried the latest VM 3.4.3.9989 ?
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.10 PHP 7.0.33
Testing VM 3.5.0.10097 on Joomla 3.9.10

chrisb_

  • Beginner
  • *
  • Posts: 3
  • A beginner
Re: Product category issues post virtuemart upgrade
« Reply #4 on: November 29, 2018, 23:42:51 pm »
Yes i have that version installed

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8962
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.4.2
Re: Product category issues post virtuemart upgrade
« Reply #5 on: November 30, 2018, 09:23:59 am »
have you an admin template over rides?
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

chrisb_

  • Beginner
  • *
  • Posts: 3
  • A beginner
Re: Product category issues post virtuemart upgrade
« Reply #6 on: November 30, 2018, 10:38:18 am »
No, I don't have template overrides.

But, I have also noticed a javascript error in product edit page:
TypeError: n.fancybox.defaults is undefined

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27480
  • Always on vacation
    • Jenkin Hill Internet
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.10 PHP 7.0.33
Testing VM 3.5.0.10097 on Joomla 3.9.10