Author Topic: Translation in backend doesn't work with other user group than Superuser  (Read 479 times)

testy

  • Beginner
  • *
  • Posts: 8
  • A beginner
Our webshop has two languages: Dutch (default) and English. The product description in the backend is translated/switched when you're logged in as a user. But there is also a group Webmasters. When they edit a product and click on the flag, the default description isn't translated. Even when they have all Joomla rights. Is this a bug of VirtueMart? Or is there a setting/right I'm missing?
The shop runs VirtueMart 3.4.0.

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3570
  • using Matomo instead of Google Analytics
Re: Translation in backend doesn't work with other user group than Superuser
« Reply #1 on: September 28, 2018, 21:46:29 pm »
If you go to 'Users' > 'Groups' > 'Options' > 'VirtueMart' from the top menu, does your 'Webmasters' group have assigned the necessary permissions?
Which editor do you have selected in the Joomla configuration? Usually TinyMce and JCE do save VirtueMart translations.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

testy

  • Beginner
  • *
  • Posts: 8
  • A beginner
Re: Translation in backend doesn't work with other user group than Superuser
« Reply #2 on: September 29, 2018, 16:27:21 pm »
The combination of your two tips solved the mystery Jjk.
I tried it with no editor selected and that worked. So it had to be something with JCE Editor. You're tip about permissions gave me the idea to look in the JCE profile. There is also a permissions option. The user group wasn't selected because it's a new group. I checked the group, saved the profile and the problem was solved.