Author Topic: TCPDF bad encoding (+why is it still an issue?)  (Read 242 times)

EvanGR

  • Jr. Member
  • **
  • Posts: 153
TCPDF bad encoding (+why is it still an issue?)
« on: September 15, 2018, 11:03:28 am »
Hello,

I am getting messed characters (???????) in generated PDF files (intended to be in the greek language) in a new VM3.2.15 installation. I remember this being a very longstanding issue from the VM2 days...

1) TCPDF 1.0.5 Component seems to be installed.

2) I have the separate tcpdf zip installation file. I recall I may need to manually extract and place some files/fonts somewhere. Any specifics on the files and paths?

3) Why is this still an issue?

Thanks

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27097
  • Always on vacation
    • Jenkin Hill Internet
Re: TCPDF bad encoding (+why is it still an issue?)
« Reply #1 on: September 15, 2018, 11:33:14 am »
I guess you don't have a suitable Greek font installed in /libraries/vendor/tecnickcom/tcpdf/fonts/  ??

See https://tcpdf.org/docs/fonts/
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.9989 on Joomla 3.9.1 PHP 7.0.32
Testing VM 3.4.3.9993 on Joomla 3.9.1

EvanGR

  • Jr. Member
  • **
  • Posts: 153
Re: TCPDF bad encoding (+why is it still an issue?)
« Reply #2 on: September 15, 2018, 14:28:46 pm »
Hello and thanks for the response.

There are several files in that path (around 26... 586KB in total).

I also noticed that in the VM control panel --> Shop --> Vendor --> Invoices... I cannot select any font in the dropdown (it's blank).

Perhaps the fonts are not picked up?