Author Topic: vmError: Max quantity of product reached, new quantity in cart set to [solved]  (Read 1153 times)

MAD King

  • Jr. Member
  • **
  • Posts: 386
  • Supporter Membership - Gold
  • VirtueMart Version: Always the Latest
Hello,

Getting this error:

Quote
Error
vmError: Max quantity of product reached, new quantity in cart set to

vmError: Max quantity of product XXXXXXXXXX reached, new quantity in cart set to 3

VirtueMart 3.2.14
Joomla! 3.8.12
PHP 7.2.9
Joomla! 3.9.12
VirtueMart 3.6.2 10159

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 4387
  • Joomla & Virtuemart developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3
Re: vmError: Max quantity of product reached, new quantity in cart set to
« Reply #1 on: September 11, 2018, 18:31:11 pm »
You use stock handel.
You can disable it in config, if you want that Virtuemart not restrict max quantity.
And control if in your product you have not restrict quantity too.

Jörgen

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3149
    • Kreativ Fotografi
  • VirtueMart Version: 3.4.x
Re: vmError: Max quantity of product reached, new quantity in cart set to
« Reply #2 on: September 11, 2018, 18:36:37 pm »
Do You have vmdebug ON ?

Right now is the VM 3.2.14 not PHP 7.2 ready. The 3.2.15 is very near to be 7.2 ready. Please use PHP 7.0 meanwhile.

Jörgen @ Kreativ Fotografi
Joomla 3.9.18
Virtuemart 3.4.x
Olympiantheme Hera (customized)
This reflects current status when viewing old post.

MAD King

  • Jr. Member
  • **
  • Posts: 386
  • Supporter Membership - Gold
  • VirtueMart Version: Always the Latest
Re: vmError: Max quantity of product reached, new quantity in cart set to
« Reply #3 on: September 11, 2018, 22:30:08 pm »
Do You have vmdebug ON ?

Right now is the VM 3.2.14 not PHP 7.2 ready. The 3.2.15 is very near to be 7.2 ready. Please use PHP 7.0 meanwhile.

Jörgen @ Kreativ Fotografi

vmdebug is OFF.

When I use PHP 7.0 I get a message from Joomla

Quote
Your PHP version, 7.0.31, is only receiving security fixes at this time from the PHP project. This means your PHP version will soon no longer be supported. We recommend planning to upgrade to a newer PHP version before it reaches end of support on 2018-09-03. Joomla will be faster and more secure if you upgrade to a newer PHP version (PHP 7.x is recommended). Please contact your host for upgrade instructions.

EDIT:

vmdebug was ON. Somehow, it turned on, but I never touched it. Funny. Thanks for pointing on this direction. Still leaves the Joomla note on the PHP version.
Joomla! 3.9.12
VirtueMart 3.6.2 10159

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 4387
  • Joomla & Virtuemart developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3
Re: vmError: Max quantity of product reached, new quantity in cart set to
« Reply #4 on: September 11, 2018, 22:41:43 pm »
Forget the message PHP version 7.0.31 .... Some Joomla sites use php 5.4. I really do not understand why Joomla Team decided to show this, it only panic all Joomla administrators, site owner for nothing.

MAD King

  • Jr. Member
  • **
  • Posts: 386
  • Supporter Membership - Gold
  • VirtueMart Version: Always the Latest
Re: vmError: Max quantity of product reached, new quantity in cart set to
« Reply #5 on: September 11, 2018, 22:49:59 pm »
Forget the message PHP version 7.0.31 .... Some Joomla sites use php 5.4. I really do not understand why Joomla Team decided to show this, it only panic all Joomla administrators, site owner for nothing.

That is correct. They got me already. haha
Joomla! 3.9.12
VirtueMart 3.6.2 10159