Author Topic: VM 3.2.15 compatible with J2.5?  (Read 577 times)

EvanGR

  • Jr. Member
  • **
  • Posts: 153
VM 3.2.15 compatible with J2.5?
« on: August 07, 2018, 12:15:06 pm »
Hello,

I am working on a site migration, based on J2.5 and VM2.6.22
I plan to upgrade VM first, and Joomla afterwards. Which is the recommended VM3 version to upgrade to, which keeps J2.5 compatibility?

I first tried with latest VM 3.2.15 but quickly ended up in a completely blank website (both front-end and back-end, with no error reports in the log)

Thanks

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 3524
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: VM 3.2.15 compatible with J2.5?
« Reply #1 on: August 07, 2018, 13:22:05 pm »
You should upgrade to Joomla 3.8 if you want use Virtuemart 3.2, Joomla 2.5 is obsolete and not support.
Joomla 2.5 hit it's end-of-life (EOL) December 31, 2014. see https://extensions.joomla.org/blog/item/joomla-2-5-support-ending/
In any case the biggest problem should be on migrating some datas to Virtuemart 3.12(most are customfields related)
You have some migrator existing, but can fail in some case.
Try to disable all the plugins you can(especially system plugins)  and Virtuemart admin module.
Update Joomla, then Vm+ VM AIO.
Note that in some case, you have to first install Virtuemart 3.0.18 or 3.0.19, then install Vm 3.2
Check that you use PHP 5.6 and change to PHP 7.0, when you have update all.
The template can have some problem too, because Joomla upgrade but VM have changed many function, so you should disable your default front template if you have a blank page and use isis joomla3 default template to test front-end.

EvanGR

  • Jr. Member
  • **
  • Posts: 153
Re: VM 3.2.15 compatible with J2.5?
« Reply #2 on: August 07, 2018, 13:45:41 pm »
Thanks for your reply.

There is some confusion, because the official VirtueMart page says VM3 is Joomla 2.5 compatible:
https://www.virtuemart.net/news/465-virtuemart-3-is-here

Also, in the VirtueMart files download page, some (many) downloads are marked as J2.5 compatible (VM 3.2.14 for example):
https://dev.virtuemart.net/projects/virtuemart/files

But the result is a blank website with those versions.

I will try installing VM 3.0.19 first and see what happens.

Thanks again

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8582
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.14
Re: VM 3.2.15 compatible with J2.5?
« Reply #3 on: August 07, 2018, 17:40:55 pm »
Quote
There is some confusion, because the official VirtueMart page says VM3 is Joomla 2.5 compatible:
https://www.virtuemart.net/news/465-virtuemart-3-is-here

that post is years old .. there really should be some dates on this news

I always understood 3.2.2 (compatible J2.5 and J3.7) was the last 2.5 compat .. but I see newer ones are again being labelled
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

EvanGR

  • Jr. Member
  • **
  • Posts: 153
Re: VM 3.2.15 compatible with J2.5?
« Reply #4 on: August 08, 2018, 08:34:58 am »
Quote
There is some confusion, because the official VirtueMart page says VM3 is Joomla 2.5 compatible:
https://www.virtuemart.net/news/465-virtuemart-3-is-here

that post is years old .. there really should be some dates on this news


Probably, since it refers to the first 3.0 release. It is however the very first post in the VirtueMart frontpage.

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8582
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.14
Re: VM 3.2.15 compatible with J2.5?
« Reply #5 on: August 08, 2018, 10:59:59 am »
Max will enable the dates on these

But he also said that VM3.2.14 IS J2.5 compat after a few gaps but .15 prob not

but be aware .. no one is testing releases on such old software
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9743
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: VM 3.2.15 compatible with J2.5?
« Reply #6 on: August 20, 2018, 23:01:12 pm »
First, the really best way to update joomla and VM is the migrator of daycounts. Really cool thing. https://extensions.virtuemart.net/back-office/import-export/virtuemart-migrator-detail

Second. Yes, there was one of the vm3.2 not compatible to j2.5, but it was just a small thing, which I could fix with 3 lines, or so. So the official release up to vm3.2.14 are compatible to j2.5.

BUT vm3.2.15 uses now completly j3.5 technics, for example the autoloader. So I removed also any switches. Vm3.2.15 is actually the new vm3.4.0! The next goal is compatibility to php7.2!

So anyone who wants to work on that, you are welcome.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

mhuebler

  • Jr. Member
  • **
  • Posts: 54
    • 3D-Puzzlewelt
  • VirtueMart Version: 3.2.x
Re: VM 3.2.15 compatible with J2.5?
« Reply #7 on: August 29, 2018, 15:22:07 pm »
Max is absolutely right. A full migration works very well with daycount's migrator and it is the best way to start with the latest version of joomla and virtuemart.

dslove

  • Jr. Member
  • **
  • Posts: 76
Re: VM 3.2.15 compatible with J2.5?
« Reply #8 on: November 01, 2018, 17:57:34 pm »
Hi guys, are there any differences in the database structure between these versions (3.2.14 / 3.2.15 / 3.4.x)?

I've got all my VM shops connected to their owner's ERP software so that product availability is updated real-time and new orders are downloaded for invoicing.
Any change in the db structure could cause issues with the connector. :-[

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 3524
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: VM 3.2.15 compatible with J2.5?
« Reply #9 on: November 01, 2018, 18:34:45 pm »
compare the administrator/components/com_virtuemart/tables folders, if the files are same, it should work as before.
Another way is to check the administrator\components\com_virtuemart\install\install.sql
(only language creation table is missing in the query)

dslove

  • Jr. Member
  • **
  • Posts: 76
Re: VM 3.2.15 compatible with J2.5?
« Reply #10 on: November 01, 2018, 18:35:58 pm »
Outstanding advice, thanks x1000!!! 8)