Author Topic: server requirement extension for images in virtuemart  (Read 1032 times)

sizou_h

  • Beginner
  • *
  • Posts: 6
  • A beginner
server requirement extension for images in virtuemart
« on: July 18, 2018, 09:47:03 am »
hi
i have a question about server requirement extension.

i have a website in this server that everything works perfect... for example , see product page :
http://aflakdata.ir/farshonline/%D9%81%D8%B1%D8%B4-%D8%AF%D8%B3%D8%AA%D8%A8%D8%A7%D9%81/%DA%AF%D8%A8%D9%87-%D8%AF%D8%B3%D8%AA%D8%A8%D8%A7%D9%81-847-detail.html


then we create a backup of the website and move it to another server , but unfortunately in the new server, in product page the image of the product doesn't show:

https://farshonline.com/sina/%D9%81%D8%B1%D8%B4-%D8%AF%D8%B3%D8%AA%D8%A8%D8%A7%D9%81/%DA%AF%D8%A8%D9%87-%D8%AF%D8%B3%D8%AA%D8%A8%D8%A7%D9%81/%DA%AF%D8%A8%D9%87-%D8%AF%D8%B3%D8%AA%D8%A8%D8%A7%D9%81-847-detail.html

i think problem is associated with requirement of image extension in new server...

can you give me some guide for this problem... thank you in advance.

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 9196
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.6.8
Re: server requirement extension for images in virtuemart
« Reply #1 on: July 18, 2018, 09:50:41 am »
php gd library extension?
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27572
  • Always on vacation
    • Jenkin Hill Internet
Re: server requirement extension for images in virtuemart
« Reply #2 on: July 18, 2018, 11:07:25 am »
PHP version too old for Magic Zoom Plus?
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.6.8 10204 on Joomla 3.9.13 PHP 7.0.33

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 4046
  • Joomla & Virtuemart developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3
Re: server requirement extension for images in virtuemart
« Reply #3 on: July 18, 2018, 13:52:35 pm »
Perhaps a write access problem with magic zoom plus image cache?
This is certainly not a Virtuemart problem.

sizou_h

  • Beginner
  • *
  • Posts: 6
  • A beginner
Re: server requirement extension for images in virtuemart
« Reply #4 on: July 18, 2018, 14:20:34 pm »
i dont know what is the reason...
but im sure that the both site are the same and both version of joomla and virtuemart version and magic zoom plus are same.

but the servers are different.

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 4046
  • Joomla & Virtuemart developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3
Re: server requirement extension for images in virtuemart
« Reply #5 on: July 18, 2018, 18:02:36 pm »
Check if GD is active and GD2 in your PHP extentions
Verify write access to the cache folder.
If you use same settings it should work in the 2 servers

sizou_h

  • Beginner
  • *
  • Posts: 6
  • A beginner
Re: server requirement extension for images in virtuemart
« Reply #6 on: July 19, 2018, 12:06:30 pm »
php gd library extension?


did not work.

sizou_h

  • Beginner
  • *
  • Posts: 6
  • A beginner
Re: server requirement extension for images in virtuemart
« Reply #7 on: July 19, 2018, 12:27:48 pm »
PHP version too old for Magic Zoom Plus?

for this website (http://aflakdata.ir/farshonline) php version is this : 5.6.35

and for that website in new server (https://farshonline.com/sina) php version is this : 5.6.36

i dont think so the problem is attributed to php versions.

what you think so?

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 4046
  • Joomla & Virtuemart developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3
Re: server requirement extension for images in virtuemart
« Reply #8 on: July 19, 2018, 12:30:06 pm »
Have you checked the folder permissions ?
Else try disable the zoom and see whats happen.
And you have javascript error Virtuemart.stopVmLoading is not a function
Are the thumbs correctly generated in back-end ?

sizou_h

  • Beginner
  • *
  • Posts: 6
  • A beginner
Re: server requirement extension for images in virtuemart
« Reply #9 on: July 19, 2018, 12:53:43 pm »
Perhaps a write access problem with magic zoom plus image cache?
This is certainly not a Virtuemart problem.

the both permission of folders are 755.

this folders ofcourse
joomla/media/plg_system_vmmagiczoomplus/magictoolbox_cache

sizou_h

  • Beginner
  • *
  • Posts: 6
  • A beginner
Re: server requirement extension for images in virtuemart
« Reply #10 on: July 19, 2018, 13:14:35 pm »
when i disable the plugin of magic zoom plus , the image of product appear.

the thumbs generated correctly in backend.

and one new thing... when the name of product is in english everything is ok but when the name of product is in Persian (farsi) the problem is remaining!


Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 4046
  • Joomla & Virtuemart developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3
Re: server requirement extension for images in virtuemart
« Reply #11 on: July 19, 2018, 14:20:28 pm »
The problem is certainly magic zoom plus.
When you check the magic zoom HTML content, no code is rendered, not only the thumb is missing.
Contact the plugin dev.