Author Topic: Error after update to 3.2.14  (Read 193 times)

jabba

  • Beginner
  • *
  • Posts: 35
    • Pixed - Web Store Assistance
Error after update to 3.2.14
« on: July 12, 2018, 09:54:52 am »
Hello, i'm developing a plugin that adds multiple products to the cart from. From the last version of Virtuemart everything is ok. From the version 3.2.14 if I try to add multiple products i get the error "Please enter a valid quantity for this item". Did something changed in the way we can add products to cart? Where can i find some documentation about it?
Thank you!
Gianluca Gabella - CEO & Web Developer @ Pixed s.n.c.b - www.pixed.it

Jörgen

  • Global Moderator
  • Full Member
  • *
  • Posts: 1665
    • Kreativ Fotografi
  • VirtueMart Version: 3.2.12
Re: Error after update to 3.2.14
« Reply #1 on: July 12, 2018, 10:39:38 am »
I don´t remember any mention about this. My best advise right now is to make a file comparison between the earlier version and VM 3.2.14.

regards

Jörgen @ Kreativ Fotografi
Joomla 3.8.3
Virtuemart 3.2.12
Olympiantheme Hera (customized)

jabba

  • Beginner
  • *
  • Posts: 35
    • Pixed - Web Store Assistance
Re: Error after update to 3.2.14
« Reply #2 on: July 12, 2018, 10:47:07 am »
Thank you for your answer. Is there a list of the modified files? Or do you know in which file the adding to cart is handled? Thank you
Gianluca Gabella - CEO & Web Developer @ Pixed s.n.c.b - www.pixed.it

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 7994
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.14
Re: Error after update to 3.2.14
« Reply #3 on: July 12, 2018, 10:51:11 am »
fe com_virtuemart/helpers/cart.php + the JS  com_virtuemart\assets\js\vmprices.js
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26971
  • Always on vacation
    • Jenkin Hill Internet
Re: Error after update to 3.2.14
« Reply #4 on: July 12, 2018, 11:12:32 am »
Is there a list of the modified files?

All changes are noted in the repository.  http://dev.virtuemart.net/projects/virtuemart/repository
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM..3.4.0.9935 on Joomla 3.8.12 PHP 7.0.31

jabba

  • Beginner
  • *
  • Posts: 35
    • Pixed - Web Store Assistance
Re: Error after update to 3.2.14
« Reply #5 on: July 12, 2018, 11:16:39 am »
Thank you all for your answers
Gianluca Gabella - CEO & Web Developer @ Pixed s.n.c.b - www.pixed.it