Author Topic: Unsupported UPS Developer Kit API URL Will Be Eliminated  (Read 722 times)

ProRaceSupply

  • Beginner
  • *
  • Posts: 14
Unsupported UPS Developer Kit API URL Will Be Eliminated
« on: June 28, 2018, 03:22:56 am »
Today I got an email stating "Effective December 31, 2018 UPS will disable all unsupported Developer Kit API URLs.

You are receiving this notification because our records indicate you are using an unsupported API URL (https://www.ups.com/ups.app/xml/ API name.) for UPS Developer Kit API transactions. Continued use of the URLs will subject your customers to unexpected outages and loss of packages with UPS.  To ensure you are using the correct URL for processing, we’ve made the latest version available in the Developer guide: https://onlinetools.ups.com/ API name. It should be used for all UPS Developer Kit API transactions."



So obviously I want to update my plugin.  I'm using the ISTRAXX one.  before I below another $75 like when they nailed me for the credit-card one (that never worked) I want to ensure the ISTRAXX shipment plugin for Joomla 2.5 uses the new API URL.

Does anyone know?  Have not received a response to this question from them.

Thanks,

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27031
  • Always on vacation
    • Jenkin Hill Internet
Re: Unsupported UPS Developer Kit API URL Will Be Eliminated
« Reply #1 on: June 28, 2018, 10:34:57 am »

 Joomla 2.5


Really? Or is that a typo? 
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.0.9935 on Joomla 3.8.12 PHP 7.0.31
Testing VM 3.4.0.9941 on Joomla 3.8.12

Jörgen

  • Global Moderator
  • Full Member
  • *
  • Posts: 1753
    • Kreativ Fotografi
  • VirtueMart Version: 3.2.12
Re: Unsupported UPS Developer Kit API URL Will Be Eliminated
« Reply #2 on: June 28, 2018, 11:09:27 am »
In VM extensions it actually sais Joomla 2.5 and Joomla 3.0. Placing the 2.5 on top.

So it is easy to take the 2.5 as the "latest" support.

I assume that the plugin supports the latest UPS URL's and if it doesn´t You will surely get an update if You buy the plugin.

Jörgen @ Kreativ Fotografi
Joomla 3.8.3
Virtuemart 3.2.12
Olympiantheme Hera (customized)

ProRaceSupply

  • Beginner
  • *
  • Posts: 14
Re: Unsupported UPS Developer Kit API URL Will Be Eliminated
« Reply #3 on: June 28, 2018, 15:48:26 pm »
Really? Or is that a typo? 

How is this helpful?  Thats the first version the plugin supposedly supports. 

Allow me to step up on my soapbox for a moment:

You do realize how difficult can be to move between Joomla versions when it precipitates a cascade of other updates that are often fraught with issues.  When we did migrate this site from 2.5 to 3.x it took weeks of debugging jquery issues with the resulting Joomla/VM versions.  We have a business to run.  Every plugin promises "support" but that support usually consists of the following:  "One of your other plugins is causing a conflict with ours.  You need to eliminate that one or fix it then ours will work."  Now multiply that times 15 or so. 


Thank you Jorgen - I would assume so also - but of course I've been burned by assuming as such before.

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 3459
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: Unsupported UPS Developer Kit API URL Will Be Eliminated
« Reply #4 on: June 28, 2018, 19:04:29 pm »
Really? Or is that a typo? 

How is this helpful?  Thats the first version the plugin supposedly supports. 

Allow me to step up on my soapbox for a moment:

You do realize how difficult can be to move between Joomla versions when it precipitates a cascade of other updates that are often fraught with issues.  When we did migrate this site from 2.5 to 3.x it took weeks of debugging jquery issues with the resulting Joomla/VM versions.  We have a business to run.  Every plugin promises "support" but that support usually consists of the following:  "One of your other plugins is causing a conflict with ours.  You need to eliminate that one or fix it then ours will work."  Now multiply that times 15 or so. 


Thank you Jorgen - I would assume so also - but of course I've been burned by assuming as such before.

If you dont hack the core files and only use overrides, you have not so many problem to update.
I managed to update many sites in 3 or 4 hours, including template, component and plugins.
So, if you do the test in a staging of your main site, it's not a concern
Note that most time, the template was obsolete and we decided to change this(because old framework not full responsive), i dont calculate this time, but this have nothing to do with the updates.

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8415
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.14
Re: Unsupported UPS Developer Kit API URL Will Be Eliminated
« Reply #5 on: June 30, 2018, 13:19:01 pm »
Can only agree with Studio 42

My "normal time" I quote for upgrades is also 4 hours

If a modern bespoke template is needed to any design this is also an additional ~ 4 hours

This is of course for non core changes etc sites... debugging of these takes what it takes - or new extensions
the key here is use over rides and accept that templates will need some refreshing/recoding..
If your web support is constantly hacking your site to achieve solutions then find a better web support...

It never ceases to amaze me the number of companies that seem to think a website needs no maintenance or rebuilds over its life time...
It is a business tool/investment just like any other

do they also never service their vehicles or update their company IT as well etc?  :-[
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

ProRaceSupply

  • Beginner
  • *
  • Posts: 14
Re: Unsupported UPS Developer Kit API URL Will Be Eliminated
« Reply #6 on: June 30, 2018, 16:40:06 pm »
Can only agree with Studio 42 My "normal time" I quote for upgrades is also 4 hours If a modern bespoke template is needed to any design this is also an additional ~ 4 hours This is of course for non core changes etc sites... [

 Sure if you have the most BASIC of installations upgrades are simple.  ...but a highly functioning site that includes the features consumers want (a decent search engine, filtering and attributing, etc..) isn't going to be that way because you will be installing add-ons.  This and updating templates *has to* be included in time because a template that was good 2 years ago does not reflect the desires of the website consumer today.  Thats typically where the time goes for me.  The core is the easy part.  Its coordinating all those other items with OS upgrades and changes to PHP behavior, jquery versions, etc.. that end up the difficult part.

Lets keep this on topic if you don't mind.  My site doesn't have "hacks" from "web support" because I maintain it.  I've got 25 years in I.T. sonny - I was probably coding while you were riding a tricycle.  :)


jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27031
  • Always on vacation
    • Jenkin Hill Internet
Re: Unsupported UPS Developer Kit API URL Will Be Eliminated
« Reply #7 on: June 30, 2018, 20:05:34 pm »
Laddie, I was writing code back in the early 1970s as an early adopter in the NHS building machine-computer-human interfaces. I make that getting over 45 years IT now.  But that is irrelevant to what I do now. GJC has probably more years under his belt than me.... 

Like you, I believe in keeping sites up to date wherever possible, but not all clients listen to advice as it may cost them money. 

FYI, iStraxx, the key of your first post is nothing to with us here, we are mere volunteers in this forum, but like you I will be checking this plugin in a couple of months while fulfilling a contract to update an old US based VM site which still uses VM1.1 and has only had "patches" applied by their (now deceased) "IT guru" since 2007.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.0.9935 on Joomla 3.8.12 PHP 7.0.31
Testing VM 3.4.0.9941 on Joomla 3.8.12

Jörgen

  • Global Moderator
  • Full Member
  • *
  • Posts: 1753
    • Kreativ Fotografi
  • VirtueMart Version: 3.2.12
Re: Unsupported UPS Developer Kit API URL Will Be Eliminated
« Reply #8 on: June 30, 2018, 22:03:28 pm »
He he, Nr of years are not that important, I know kids that can beat me in many ways, and I have known experienced programmers that shouldn´t call themself programmers. I am not as old in the game as Jenkins I have only been programming for a living for 29 years, so I have a bit to go.

I don´t want to see a war here, just making a point regarding your not so nice reply, please only things relevant to the issue.

have a nice evening

Jörgen @ Kreativ Fotografi
Joomla 3.8.3
Virtuemart 3.2.12
Olympiantheme Hera (customized)

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 3459
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: Unsupported UPS Developer Kit API URL Will Be Eliminated
« Reply #9 on: June 30, 2018, 23:07:52 pm »
My first programs was on amstrad CPC 464 and atari 520ST, before PC, this was in years 1982/84, so you are a teenager for us ;)
Seriously, i know that in some case, when you need to code yourself plugin or add feature, update can be longer, but not because most existing component.
jQuery 1.6 to jQuery 2.x should work most case with same code and now you can load jquery from Joomla since 3.0 and because most developper use Joomla jQuery now, you have not all the conflict you had with Joomla 2.5
So yes, a moment you loose time, but when you see the difference in the backend and all advantage using Joomla 3.X, you dont loose any money, you only invest in the future.
Eg direct link to edit articles from the menu items, module settings, easier to update, PHP7 support(most time 10% to 30%  faster), responsive back-end, better editors, bootstrap support ...
But it's your choice, not mine, we're just trying to help you, not blaming you.

AH

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2810
  • VirtueMart Version: 3.4
Re: Unsupported UPS Developer Kit API URL Will Be Eliminated
« Reply #10 on: July 01, 2018, 10:44:49 am »
Back to the topic

Looks like no one posting here (other than you) uses the UPS plugin with the latest UPS API.

As noted earlier by jorgen - iStraxx UPS - version indicates what it supports - under Extensions Specifications

Their refund policy says you get a refund if unsolvable bug etc https://extensions.virtuemart.net/component/content/article/16-istraxx/18-what-you-get-license-support-updates-and-refunds

You contacted the supplier of the plugin and received no reply.  In my book that sends enough of a message.

If anyone here posts a positive response to the support for the latest UPS API - for your version of J and VM (which you never state) then you are good to go - otherwise you have to rely on their refund or "bug" fixing policy.

However you also stated
Quote
before I below another $75 like when they nailed me for the credit-card one (that never worked)

Which seems to indicate that you purchased a plugin from iStraxx which did not function as specified - and for which you did not receive a refund - that appears to be at odds with their stated refund policy.
In which case you may be better contacting them again


PS:
Just for completeness  (Sinclair zx80 - 1977 ;D )
regards
A

Joomla 3.8.13
php 7.1

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8415
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.14
Re: Unsupported UPS Developer Kit API URL Will Be Eliminated
« Reply #11 on: July 03, 2018, 15:44:12 pm »
I think I got a good grounding in logic from my time at Bletchley Park as a junior member of the Enigma project a few years back.
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

AH

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 2810
  • VirtueMart Version: 3.4
Re: Unsupported UPS Developer Kit API URL Will Be Eliminated
« Reply #12 on: July 03, 2018, 16:13:49 pm »
"I think I got a good grounding in logic from my time at Bletchley Park as a junior member of the Enigma project a few years back."

By "junior Member", do you mean Tea-Boy?
regards
A

Joomla 3.8.13
php 7.1