Author Topic: Product images not displaying on front end product page  (Read 368 times)

sean_nwfs

  • Beginner
  • *
  • Posts: 34
  • A beginner
    • SymptoPro Fertility Education
Product images not displaying on front end product page
« on: June 27, 2018, 19:26:47 pm »
I am not able to display multiple product images in my product pages. I can see the initial image on the category view but if you visit a specific product page, it doesn't show an image unless I upload the image on the back end twice.  If I upload multiple images it only shows the second image and the thumbnail is blank. All jQuery boxes under config>template are enabled as has been recommended elsewhere. I have also synchronized media. How can I have product images show up on the product page?

https://staging4.symptopro.org/catalog/books-brochures-and-supplements/digital-thermometer-detail.html (Only one image on back end.)
https://staging4.symptopro.org/catalog/books-brochures-and-supplements/a-couples-guide-to-fertility-detail.html (Image uploaded twice on back end so it will show one image on product page.)

Joomla 3.8.8
VM 3.2.14
Joomla 3.8.8
VM 3.2.14

Jörgen

  • Global Moderator
  • Full Member
  • *
  • Posts: 1750
    • Kreativ Fotografi
  • VirtueMart Version: 3.2.12
Re: Product images not displaying on front end product page
« Reply #1 on: June 27, 2018, 21:28:26 pm »
This is a custom template, is it ready for vM 3.2.14 and Joomla 3.10 ?

regards

Jörgen @ Kreativ Fotografi
Joomla 3.8.3
Virtuemart 3.2.12
Olympiantheme Hera (customized)

sean_nwfs

  • Beginner
  • *
  • Posts: 34
  • A beginner
    • SymptoPro Fertility Education
Re: Product images not displaying on front end product page
« Reply #2 on: June 27, 2018, 23:21:01 pm »
If you mean is it working, yes (aside from this issue). Will Template Monster claim to support it, probably not. I do have a staging copy with the build it was created on and it is doing the same thing.
Joomla 3.8.8
VM 3.2.14

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 3458
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: Product images not displaying on front end product page
« Reply #3 on: June 27, 2018, 23:48:41 pm »
Do you use .jpeg, because i see that your banner use .jpeg ?
Try to rename the extention from .jpeg to .jpg before upload product image, if it's the case.

sean_nwfs

  • Beginner
  • *
  • Posts: 34
  • A beginner
    • SymptoPro Fertility Education
Re: Product images not displaying on front end product page
« Reply #4 on: June 27, 2018, 23:57:15 pm »
Most images are .png.  I'll try and comb through and swap out any .jpeg but by the look of my files the ones I have are .jpg.
Joomla 3.8.8
VM 3.2.14

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 3458
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: Product images not displaying on front end product page
« Reply #5 on: June 28, 2018, 03:21:58 am »
In the category the image display fine.
So the problem is in the template not in virtuemart.