Author Topic: HTTPS in Shop not working  (Read 734 times)

SSB

  • Beginner
  • *
  • Posts: 1
  • A beginner
HTTPS in Shop not working
« on: June 15, 2018, 09:21:40 am »
Hi,

we recentely set up a new web page including an online shop and are now looking forward to publishing the new web page... However, we are still experiencing problems in the web shop area:

- After putting an item in the shopping cart, we are shown a popup with the status message that the item has been added to the cart. Part of the popup is a "show shopping cart" button. It's possible to click this button, however nothing happens afterwards.
- For some reason we are also having constant problems when calling any websites with "https". After entering the shopping cart it is not possible to click on the buttons to enter a shipping or billing address. The website always return a ERR_CONNECTION_TIMED_OUT message. Interestingly, the website can be called, as soon as I manually turn the https into an http in the address bar.

This has been the case using different templates, so at this stage I believe the issues must be somewhere else. Is this a server problem of any sort or can this be fixed in the Joomla backend?

I am currently working with VirtueMart 3.2.12 on Joomla! 3.8.5 using PHP 5.6.36

Thank you very much for any help in advance and all the best
 / Al

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8413
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.14
Re: HTTPS in Shop not working
« Reply #1 on: June 15, 2018, 10:42:09 am »
Have you got a valid security certificate for the domain?

the show shopping cart:  after clicking you need to check if any errors are being returned - JS or server

what is the link of the button?

Have you a menu pointing to your cart?

You will receive a lot more help IF you provide live details were we can check what is going on
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3361
  • using Matomo instead of Google Analytics
Re: HTTPS in Shop not working
« Reply #2 on: June 15, 2018, 10:51:09 am »
Perhaps it is this? https://www.deskdecode.com/err_connection_timed_out/
Also, I would suggest to update to Joomla 3.8.8 and VirtueMart 3.2.14. It doesn't make sense to start a new shop with outdated releases. There were vulnerabilities detected in your installed versions which have been fixed in later releases. See: http://virtuemart.net/news/489-virtuemart-3-2-14-security-release-and-enhanced-invoice-handling.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27029
  • Always on vacation
    • Jenkin Hill Internet
Re: HTTPS in Shop not working
« Reply #3 on: June 15, 2018, 12:32:27 pm »
If you don't (yet) have a SSL certificate on your server then turn off "Enable SSL for sensitive areas (recommended)" in VirtueMart Configuration/Shop/Shop Settings

Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.0.9935 on Joomla 3.8.12 PHP 7.0.31
Testing VM 3.4.0.9941 on Joomla 3.8.12

Hurt

  • Beginner
  • *
  • Posts: 1
  • A beginner
    • Hurtownia odzieży damskiej
Re: HTTPS in Shop not working
« Reply #4 on: July 06, 2018, 22:43:04 pm »
Try to add to htaccess:
Code: [Select]
RewriteCond %{HTTPS} on
RewriteRule (.*) http://%{HTTP_HOST}%{REQUEST_URI} [R=301,L
Zapraszam na zakupy na https://www.hurt-odziez.pl

papair

  • Beginner
  • *
  • Posts: 1
  • A beginner
    • SBOBETClub168
Re: HTTPS in Shop not working
« Reply #5 on: September 21, 2018, 08:40:23 am »
Try to add to htaccess:
Code: [Select]
RewriteCond %{HTTPS} on
RewriteRule (.*) http://%{HTTP_HOST}%{REQUEST_URI} [R=301,L
Thanks