Author Topic: Custom Fields is not displayed in the categories view  (Read 208 times)

vlopez

  • Beginner
  • *
  • Posts: 21
Custom Fields is not displayed in the categories view
« on: June 08, 2018, 13:30:08 pm »
Joomla: 3.8.8
Virtuemart: 3.2.14

Greetings.

I am not able to display custom fields in products in the category view.
I have copied the sublayouts folder to template / mytemplate / html / com_virtuemart
I have reviewed the files:
customfields.php
products.php
addtocart.php
categoríes.php (little relevant to the problem)

I have made some modification in the file products.php to see if it was rendered and actually rendered.

As a clue: in the configuration of Virtuemart I observed that if in the Templates Configuration section Templates and Designs in the Category Design option, I select categories instead of default, the categories view goes blank.

Not is a template problem because I test with others templates, and ocurrs the same.

In addition, I notice that in the template I have defined in the front-end class vm-customfields-wrap, but it contains nothing.

Is it something related to the configuration?. There are any way to solve it?

Thank you.

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 3241
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: Custom Fields is not displayed in the categories view
« Reply #1 on: June 08, 2018, 13:38:46 pm »
If you have a blank page, then you have a PHP error in a file.
change PHP debug to "maximum" in the Joomla config, so you see a report about your error.

vlopez

  • Beginner
  • *
  • Posts: 21
Re: Custom Fields is not displayed in the categories view
« Reply #2 on: June 08, 2018, 14:49:02 pm »
I have set the joomla debug level to the maximum and debug enabled.
Some errors appear in the databases of duplicate queries and "could not use the index key".
In errors of languages the error appears
JROOT / language / en-GB / en-GB.lib_joomla.ini: error (s) in line (s) 233
I think they are not related to the problem.
The blank page is displayed when I select Categories in the Templates Configuration section Templates and Designs in the Category Design option

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 3241
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: Custom Fields is not displayed in the categories view
« Reply #3 on: June 08, 2018, 15:50:53 pm »
Not Joomla debug !
But Joomla global configuration > Server > Server settings : Error Reporting "maximum"