Author Topic: virtumart issue with PHP Version 7.2.3  (Read 1169 times)

Ankitasingh

  • Beginner
  • *
  • Posts: 1
  • A beginner
virtumart issue with PHP Version 7.2.3
« on: June 30, 2018, 14:34:15 pm »
i have installed virtumart 3.2.14 and my php version is  7.2.3 . I have created a product and when open a product detail page on front end there are lots of notices and warning

Please check below url :

https://prnt.sc/k150oe

Thanks,

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27426
  • Always on vacation
    • Jenkin Hill Internet
Re: virtumart issue with PHP Version 7.2.3
« Reply #1 on: June 30, 2018, 19:34:55 pm »
Use PHP7.1.x  Not all issues with PHP7.2 have been reolved, especially in some third party VM extensions.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.8 PHP 7.0.33
Testing VM .3.6.0.10075 on Joomla 3.9.8

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 3826
  • Joomla & Virtuemart developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3
Re: virtumart issue with PHP Version 7.2.3
« Reply #2 on: June 30, 2018, 23:23:00 pm »
Your warning say, you can have problem in next release. not that you have an error, use normal error reporting in Joomla config >server, to disable this message if you are not a coder solve the problem.
But it's safer to use PHP 7.1 in all case.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9838
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: virtumart issue with PHP Version 7.2.3
« Reply #3 on: August 20, 2018, 23:11:03 pm »
Thank you Ankitasingh. Good to know, it must be the next task before the next release.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

manub23

  • Beginner
  • *
  • Posts: 20
Re: virtumart issue with PHP Version 7.2.3
« Reply #4 on: May 20, 2019, 20:33:22 pm »
Now any issue with PHP 7.2.x with new Virtumart ?.

I am planning to use PHP 7.2.11 for Joomla 3.9.6 with VM 3.4

Please update me. Thanks

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 8892
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.4.2
Re: virtumart issue with PHP Version 7.2.3
« Reply #5 on: May 20, 2019, 22:38:38 pm »
all mine running problem free on 7.2
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation