Author Topic: Added new categories for products; mails not working?  (Read 368 times)

mailblade

  • Jr. Member
  • **
  • Posts: 85
  • A beginner
Added new categories for products; mails not working?
« on: February 07, 2018, 17:31:07 pm »
Never mind, I think there was just something wrong with my mail server and it was taking a very long time to get through. All is working!

I added 2 categories for my products.

I put them both into menu items. So now, all-together I have 3 menu items.

The first menu item shows a list of all products, without any filtering or categorisation.  The second and third ones are both seperate categories.

Now, for the first menu item, I copied the "default.php" file in "html/com_virtuemart/category", customised the copy and renamed it to "layout1". I then went into the back-end and by the menu settings for this menu item, under "virtuemart category view settings" I changed the override to my new layout (layout1).

For the other two menu items: both are using the "default.php" file, although they are both displaying different categories. I can only add items to the cart from the second and third categories, the first one is literally just a read-me file which displays the other two products in the categories together on one page.

I've tried setting the override to "no override" but it won't budge. Could there be a conflict of sorts? I was so glad at finding a solution for showing the two categories as well as them grouped together, and now my mails won't send. It's just constant problems. I don't know why it won't work.

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 3402
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: Added new categories for products; mails not working?
« Reply #1 on: February 07, 2018, 18:13:06 pm »
What have mail to do with this category items ?
If you have cart problem, you should add a menu item to virtuemart>cart
If you dont want see this lin in the menu, simply use a new menu and don't add a module

mailblade

  • Jr. Member
  • **
  • Posts: 85
  • A beginner
Re: Added new categories for products; mails not working?
« Reply #2 on: February 07, 2018, 20:41:44 pm »
The reason I mention it, is before I added the categories, the mails were working with the cart.

My cart is a menu item.

What do you mean by your last line?

Studio 42

  • Contributing Developer
  • Sr. Member
  • *
  • Posts: 3402
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: Added new categories for products; mails not working?
« Reply #3 on: February 07, 2018, 21:20:50 pm »
Quote
What do you mean by your last line?
Add a new Joomla menu link to the cart and try if it help.