Author Topic: English strings in customer mail  (Read 535 times)

sandomatyas

  • Jr. Member
  • **
  • Posts: 153
English strings in customer mail
« on: November 04, 2017, 09:35:41 am »
I run a Hungarian webshop which uses Hungarian language only, latest Joomla and Virtuemart and Rupostel's OPC.
It works well but when I order something the confirmation mail is half Hungarian and half English
English words are the user fields titles (City, Address, Phone, etc), the product headers (SKU, Price, Qty) except the "product name", the "total" title, order status and Page 1/1. Every other strings are Hungarian.
OPC extensions allows append order details information to the thank you page, the same strings are also English but when I check my order details again, everything is Hungarian.
I tried to disable every Rupostel plugins, remove all template overrides but I got the very same problem.
I also tried to install another language (German) to check if the language files have any error but got the same result.
Here is a screenshot: https://snag.gy/W5X9gp.jpg

Any idea?

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3187
  • using Piwik instead of Google Analytics
Re: English strings in customer mail
« Reply #1 on: November 04, 2017, 13:42:22 pm »
I can see only an empty Snaggy page following your link. Which versions of Joomla and VM?
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

Studio 42

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2410
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: English strings in customer mail
« Reply #2 on: November 04, 2017, 18:01:08 pm »
Vm version ?

sandomatyas

  • Jr. Member
  • **
  • Posts: 153
Re: English strings in customer mail
« Reply #3 on: November 07, 2017, 14:25:01 pm »
Joomla 3.8.1, VM 3.2.4
The corrected screenshot: https://snag.gy/EyD7bq.jpg

jflash

  • 3rd party VirtueMart Developer
  • Beginner
  • *
  • Posts: 16
Re: English strings in customer mail
« Reply #4 on: November 07, 2017, 15:00:33 pm »
I have same issue. Language string overwrite under Joomla was my solution :) Joomla 3.8.1 and VM 3.2.4 (under 3.2.2 was same).

Studio 42

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2410
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: English strings in customer mail
« Reply #5 on: November 08, 2017, 00:43:40 am »
sandomatyas, do you changed the default field names?
Check administrator/index.php?option=com_virtuemart&view=userfields and open your field
Eg. email field title should be COM_VIRTUEMART_REGISTER_EMAIL

sandomatyas

  • Jr. Member
  • **
  • Posts: 153
Re: English strings in customer mail
« Reply #6 on: November 08, 2017, 13:03:22 pm »
I use language constas everywhere.
But when I open the order from the link which is in the mail VM displays it correctly. It's only in the mail.

Studio 42

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2410
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: English strings in customer mail
« Reply #7 on: November 08, 2017, 18:29:11 pm »
Have you check the settings in the VIrtuemart config about language in email ?
VIrtuemart config>email>Invoice in user language

sandomatyas

  • Jr. Member
  • **
  • Posts: 153
Re: English strings in customer mail
« Reply #8 on: November 10, 2017, 07:17:14 am »
I tried both ways even with/without login

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3187
  • using Piwik instead of Google Analytics
Re: English strings in customer mail
« Reply #9 on: November 10, 2017, 17:22:39 pm »
Did you try Joomla's 'Debug language' on that page already? It should list the problems in your language files.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

sandomatyas

  • Jr. Member
  • **
  • Posts: 153
Re: English strings in customer mail
« Reply #10 on: November 24, 2017, 16:02:06 pm »
yep, but it's half Hungarian half  English?
You can try it yourself, I built a very basic site (Joomla! 3.8.2 and VM 3.2.6) with one category and one product
http://vmlang.tk
After you place an order also the confirm message is half english: https://snag.gy/jucbyW.jpg

Studio 42

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2410
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: English strings in customer mail
« Reply #11 on: November 24, 2017, 21:24:11 pm »
I had a problem on my own plugin loading language,
It seems that if you dont force language, this get not loaded anymore in Joomla 3.8.2(it was not the case in the releases before)
Eg if you load 2 language files

            $lang->load($name, $path,en-GB);
            $lang->load($name, $path);
the default language is not loaded anymore, but only en-GB.
I think it was not the case before in Joomla.
Now
            $lang->load($name, $path);
fallback to english i think.

Note that i have not do more test, but i had the problem adding en-GB and default, so perhaps language handle changed in Joomla ?

sandomatyas

  • Jr. Member
  • **
  • Posts: 153
Re: English strings in customer mail
« Reply #12 on: November 24, 2017, 21:42:47 pm »
It seems disabling **Use english as fallback for untranslated strings** solved the problem, but in this case I get language strings if there is a missing translation and there are strings which aren't in transifex yet (e.g. COM_VM_CFG_ORDERTRACKING)
------------------------------------------
update: it helped on my demo site but not on the live site, so I'm a bit clueless

Studio 42

  • Contributing Developer
  • Full Member
  • *
  • Posts: 2410
  • Joomla & Virtuemart addon developper
    • Studio 42 - Virtuemart & Joomla extentions
  • VirtueMart Version: 2.6 & 3.0.x.y
Re: English strings in customer mail
« Reply #13 on: November 25, 2017, 02:55:29 am »
Have you try to activate language debug in Joomla, to check if you have problems in your language.ini files ?
You get a report on the bottom with loaded files and errors.

sandomatyas

  • Jr. Member
  • **
  • Posts: 153
Re: English strings in customer mail
« Reply #14 on: November 25, 2017, 05:51:13 am »
yes and no errors
---------------
update: I was able to get proper message once when language debug was enabled but not after I turned off