Author Topic: Authorize.net TLS Disablement. Will Virturemart/plugin handle this?  (Read 573 times)

sugapablo

  • Beginner
  • *
  • Posts: 3
I received the following from my payment gateway, Authorize.net:

Quote
TLS Disablement Reminder
Your Payment Gateway ID: xxxxxx
Dear Authorize.Net Merchant:
As you may be aware, new PCI DSS requirements state that all payment systems must disable early TLS by 2018.       
TLS FAQs
Merchant Interface
 
Transport Layer Security (TLS), is a technology used to encrypt sensitive information sent via the Internet. TLS is the replacement for Secure Sockets Layer (SSL).
 
In preparation for this requirement, Authorize.Net plans to disable TLS 1.0 and TLS 1.1 on the following dates: February 28, 2018

I am using:
  • Authorize.net AIM Plugin 3.2.4 (August 23 2017) from The VirtueMart Development Team.
  • VirtueMart 3.2.4
  • Joomla! 3.8.1 Stable
  • PHP 7.0.22

I see no settings anywhere in VM regarding TLS, nor in the plugin.  Can I assume all is already set up to handle disabling TLS 1.0 and 1.1 and running everything over 1.2?  Do I need to take any action?
   

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26917
  • Always on vacation
    • Jenkin Hill Internet
Re: Authorize.net TLS Disablement. Will Virturemart/plugin handle this?
« Reply #1 on: October 10, 2017, 23:18:46 pm »
Yup, nothing to do with VirtueMart.  TLS or Transport Layer Security refers to the security protocol on your server. As long as you have a good security certificate on the server you will most likely have TLS1.2 - if in doubt check with your host.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM.3.2.15.9866 on Joomla 3.8.10 PHP 7.0.30

Testing VM.3.2.15.9898 on J3.8.10

hotrod

  • Jr. Member
  • **
  • Posts: 102
  • Silver Supporting Member
Re: Authorize.net TLS Disablement. Will Virturemart/plugin handle this?
« Reply #2 on: January 27, 2018, 14:43:54 pm »
I have been on the same dedicated with my host for 7 years and come to find out my box does not support TLS 1.2  being forced to move to another platform..   I think this is going to affect a lot of people that think they are ok..  To check, all you need to do is use this URL in your authorize.net config..

TEST:
https://test.authorize.net/gateway/transact.dll

TLS 1.1 to be turned off on Feb 28th. 
VirtueMart 2.6.8 (Patched 9/18)
Joomla 2.5.22
PHP Version    5.4.32 
Dedicated Server.
Proud Virtuemart Supporter http://forum.virtuemart.net/index.php?topic=124355.0