Author Topic: Forgot Password/Username take me back to the homepage!?  (Read 717 times)

ch1vph

  • Beginner
  • *
  • Posts: 38
  • A beginner
Forgot Password/Username take me back to the homepage!?
« on: October 07, 2017, 22:42:04 pm »
Hello!

Don't know if its just me but I've tried to test my Forgot Password and Forgot Username today and both links: component/users/?view=remind&Itemid=101...take me back to the homepage!?

Has anyone else had this problem occur recently I this was working for me a few weeks back. Please note to have tried to enable and disable all system plugins to see if anything was causing an issue but cannot figure it out at the moment??


VirtueMart 3.2.4 // Joomla! 3.8.1 // PHP Version 5.6.31
Site: https://ri2k.london/my-account // JA Brickstore Template on T3 Framework

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26917
  • Always on vacation
    • Jenkin Hill Internet
Re: Forgot Password/Username take me back to the homepage!?
« Reply #1 on: October 08, 2017, 00:06:07 am »
That's the usual URL.  It is a Joomla function, nothing to do with VirtueMart.  If it does not work for you tryn turning off SEF and try again. Some template developers disable the remind/reset function, to check that try using Protostar.  Otherwise ask in the Joomla forum or ask your template developer.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM.3.2.15.9866 on Joomla 3.8.10 PHP 7.0.30

Testing VM.3.2.15.9898 on J3.8.10

nfleming

  • Beginner
  • *
  • Posts: 3
Re: Forgot Password/Username take me back to the homepage!?
« Reply #2 on: February 12, 2018, 00:10:18 am »
Hi ch1vph, did you ever figure out what was causing this issue? My client has just reported the same problem occuring. The site is running J3.8.3 and VM3.2.12

Regards
Nicola

nfleming

  • Beginner
  • *
  • Posts: 3
Re: Forgot Password/Username take me back to the homepage!?
« Reply #3 on: February 12, 2018, 01:49:15 am »
Hi again, I found a post on the Joomla forum which fixed this issue for me. https://forum.joomla.org/viewtopic.php?f=706&t=951352&p=3512866#p3512866
It was the fix suggested by Toivo which worked for me, I created a new menu called "Hidden" and created the two new menu items one for User - forgotten username and one for User-reset password. This reset the page URL for the forgot username and reset password links, and they started working again.