Author Topic: Paypal processing redirecting error message We're sorry, things don't appear to  (Read 300 times)

daryl0524

  • Beginner
  • *
  • Posts: 1
  • A beginner
Hi,

Does anyone encountered or resolved this kind of error. I have an issue when I tried to check out using the paypal payment method, it redirecting to a page error

https://www.paypal.com/webapps/shoppingcart/error?flowlogging_id=6e5f4bbb85a94&code=BAD_INPUT_ERROR&mfid=1505249128204_6829bb9b291c9

Error message

We're sorry, things don't appear to be working at the moment. Please try again later.

I already checked and set all the configuration on the default settings and test it using existing paypal email account and still got the same output.

I found this source for the issue but I don't know how to solve it in the virtuemart paypal plugin

https://www.paypal-knowledge.com/infocenter/index?page=content&id=FAQ2067

Thanks in advanced


Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9372
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Hmmm, we have a similar problem. Started also this monday. I wonder, because in our case the images has https. Where did you took out the line? file, line? Do you mean in paypalstd.php line 265?
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

wbauer74

  • Beginner
  • *
  • Posts: 7
Hmmm, we have a similar problem. Started also this monday. I wonder, because in our case the images has https. Where did you took out the line? file, line? Do you mean in paypalstd.php line 265?

Here is the string of code I removed from paypalstd.php. I am using VM version 3.0.12. After removing this string Paypal standard payments work again. It is from lines 262-266

Code: [Select]
if (empty($this->_method->headerimg) OR $this->_method->headerimg == -1) {
$post_variables['image_url'] = $this->getLogoImage();
} else {
$post_variables['cpp_header_image'] = JURI::base() . 'images/stories/virtuemart/payment/' . $this->_method->headerimg;
}

I just removed the entire string and everything works again.