Author Topic: Nothing regarding media files seems to be working  (Read 364 times)

PrPrO

  • Beginner
  • *
  • Posts: 5
Nothing regarding media files seems to be working
« on: August 25, 2017, 14:38:01 pm »
Hello,

first things first, the system information:
OS Linux a
Joomla 3.6.5
VirtueMart 3.2.4
PHP 7.0.22
Host: Siteground

Now the problem: for first, every time  I upload the image via the media tab (create new media), the image gets uploaded, but the thumbnail is nowhere to be visible. The "Used thumb url" is mostly empty, and when it is not, its pointing to a directory like this one: images/stories/virtuemart/product/resized/file-name_100x100.jpg, but this file doesn't exist, hence there is no visible thumbnail.

I have tried turning the Dynamic resizing on and off, but it doesn't change anything, it even doesn't resize the additional images in product detail page.

And it seems like the whole cart got wild, look at the shop navigation on this page: http://www.nova.clm-pro.com/store-detail/fuselage-sets/over-3m-wingspan-3

NOTE: the website is not even roughly built, so the pictures are all random and with no sense.

I would appreciate any help regarding the images and the cart itself.
Thank you in advance,
Matija

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26372
  • Always on vacation
    • Jenkin Hill Internet
Re: Nothing regarding media files seems to be working
« Reply #1 on: August 25, 2017, 15:33:57 pm »
First you should be using Joomla 3.7.5, then the images will be correctly located using the Joomla 7 convention, ie in /images/virtuemart/product/   J3.6.5 is insecure.

The thumbnails are not generated until the product is viwed on the live site page, then they are created on the fly the first time they are required.

You are using a commercial template instead of the default VM template files. Are you sure that the template is VM3.2.4 compatible?
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.6 on Joomla 3.8.2 PHP 7.0.25

Testing VM3.2.6 on J!4alpha1

PrPrO

  • Beginner
  • *
  • Posts: 5
Re: Nothing regarding media files seems to be working
« Reply #2 on: August 25, 2017, 19:22:21 pm »
I'm sorry, i thought I had the latest Joomla installed, but it was 3.6.5 and it didn't offer any updates, the site is now running on 3.7.5.

I have just checked the changelog for the template and found that the latest compatible versions are:
- Compatibility for Joomla 3.6.5
- Compatibility for Virtuemart 3.0.18

So, unfortunately it isn't compatible with either the latest Joomla or VM.

Your advice would, I assume, be to find a new template?
Is it possible to downgrade both Joomla and VM to the latest compatible version?

Thank you,
Matija

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26372
  • Always on vacation
    • Jenkin Hill Internet
Re: Nothing regarding media files seems to be working
« Reply #3 on: August 25, 2017, 23:51:03 pm »
Due to security issues you should not use a Joomla version earlier that J3.7.4 - which really is the same as 3.7.5, only one unimportant difference.  Most Joomla templates for 3.6.5 are OK with J3.7.x
You must use at least VM3.2.2 with Joomla 3.7+, but there is no difference in templaing between 3.2.2 and 3.2.4 to worry about

The most likely required template adjustments are described here:  http://forum.virtuemart.net/index.php?topic=135402.0

There are many more configuration options in the latest VM versions and often an "incompatability" is a config error.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.6 on Joomla 3.8.2 PHP 7.0.25

Testing VM3.2.6 on J!4alpha1

PrPrO

  • Beginner
  • *
  • Posts: 5
Re: Nothing regarding media files seems to be working
« Reply #4 on: August 26, 2017, 16:52:44 pm »
I have succesfully downgraded to VM 3.0.18, the last compatible version, but all the problems persist, the only thing which worked is creating new images and thumbnail.

But I still have there problems:
- thumbnails are all different size, even with dynimc resizing enabled (http://www.nova.clm-pro.com/store-detail/fuselage-sets/over-3m-wingspan-3/fuselage-set-133-detail)
- the fancybox doesn't give a option to move left or right through additional images
- it seems like the top menu "Store" and the left menu aren't connected, when I open anything on the left menu, the navigation of the store is correct
     - the left menu ("Levi") is set with one menu as the category module, which should show categories according to store, and the top one is every menu set separately and connected to correct category


Do you have anyone who could help me with this problems? I guess it should work with Joomla 3.7.5 and VM 3.0.18 since the template si compatible with this VM

Regards,
Matija

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26372
  • Always on vacation
    • Jenkin Hill Internet
Re: Nothing regarding media files seems to be working
« Reply #5 on: August 26, 2017, 17:27:43 pm »
To start with those additional images cannot have had the same width-height ratio to start with, as the thumb sizes vary between 150x22px and 150x98px. The perspective is not changed during thumb creation. The additional image css is set to just control the width of those images. This css is generated from your jch_optimize plugin so not possible to see exactly where from originally.  Optimisers like this should not be used while a site is being developed as they make debugging difficult.
If you are not bothered about perpective then use a css override. eg:
.additional-images img {
   width: 90px;
   height: 50px;
}

The lack of navigation in fancybox is a function of your template. Test this by forcing the page content to display using the default VM templates by using the url below. Fancybox navigation works then.
http://www.nova.clm-pro.com/store-detail/fuselage-sets/over-3m-wingspan-3/fuselage-set-133-detail?tmpl=component&template=protostar

As for the menu issue, it is not possible to see if that is using the default VM cat module or something else - without jhc-optimize it may be easier to see, but we are here to support VirtueMart, not third party template systems.  http://forum.virtuemart.net/index.php?topic=108212.0
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.6 on Joomla 3.8.2 PHP 7.0.25

Testing VM3.2.6 on J!4alpha1