Author Topic: VirtueMart 4.0.4 10688 and PHP 8.0.26  (Read 251 times)

modernmagic

  • Beginner
  • *
  • Posts: 18
  • A beginner
VirtueMart 4.0.4 10688 and PHP 8.0.26
« on: December 07, 2022, 02:34:37 am »
When I try to upgrade from php 7.4 to php 8.0.26 the site has the following errors/debug info:

0 - error_reporting(): Argument #1 ($error_level) must be of type ?int, string given
Call stack
#   Function   Location
1   ()   JROOT/plugins/system/vm_search_ac/vm_search_ac.php:10
2   error_reporting()   JROOT/plugins/system/vm_search_ac/vm_search_ac.php:10


Dev site:  https://modernmagic18.sg-host.com/

Does VM 4 work with PHP 8?
Or is this another themeforest template issue?

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28456
  • Always on vacation
    • Jenkin Hill Internet
Re: VirtueMart 4.0.4 10688 and PHP 8.0.26
« Reply #1 on: December 07, 2022, 13:23:36 pm »
There is no file named vm_search_ac.php in standard VM4 - a third-party extension or your template?
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 4.0.12 10777  J 3.10.11 PHP 7.4.30

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10530
  • VM4.0.7 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: VirtueMart 4.0.4 10688 and PHP 8.0.26
« Reply #2 on: December 20, 2022, 21:56:17 pm »
It is the problem with a search plugin called vm_search_ac. Just disable it.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/