Author Topic: Error Invalid extension update  (Read 133 times)

Smiley

  • Beginner
  • *
  • Posts: 7
  • A beginner
  • VirtueMart Version: VirtueMart 3.0.18
Error Invalid extension update
« on: August 13, 2017, 03:09:05 am »
Hi all,

First off some info I'm using:
Joomla: 3.6.2
Virtuemart: 3.0.18
PHP: 7.0

Ok so in my maintenance area I have Virtuemart updates and when I go to update now it gives me an error (Error Invalid extension update) and I thus can't update. ??? What am I missing here? In maintenance it also is saying that I should update to Joomla 3.7.4 but everything I read tells me to be wise and update extensions before joomla updates...so hence I'm hesitant - if this is the issue??

Also a side issue (which may or may not be linked to this one) is when I try to add a new extension through install from Web page it also comes with a Error (Error Invalid URL Unable to find install package)?

I am new to Joomla and am very frustrated with this...as I'm guessing it's something simple I am just not getting. I hope someone can point me in the right direction to fix such issues. Cheers in advance for any feedback!  :)

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26090
  • Always on vacation
    • Jenkin Hill Internet
Re: Error Invalid extension update
« Reply #1 on: August 13, 2017, 11:12:58 am »
The plugin update issue is an old problem releated to the way in which the Joomla updater worked. This was subsequently fixed.

You realise that your Joomla version is old and must be updated, but are right to wonder if some extentions may be incompatible with the most recent Joomla version, which is J3.7.4. When an issue was noticed between Joomla versions 3.6 and 3.7 a compatible VM version was released with an advisory to update published in VM news: http://virtuemart.net/news/latest-news/480-security-release-of-joomla-3-7-be-prepared

So update VM first to a recent version and then update Joomla. I update VM by downloading the relevant package file from http://dev.virtuemart.net/projects/virtuemart/files  (on live sites I am currently using VM 3.2.3.9614 ).  For updates to VM I use the Upload Package File installer and for Joomla I use the Joomla update component.    See http://forum.virtuemart.net/index.php?topic=123808.0

Note that there are enhanced configuration options in VM3.2 so it is a good idea to test the updates on a backup copy of your live site first.
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.3.9614 on Joomla 3.7.4 PHP 7.0.22

Testing VM3.2.3.9614 on J!3.7.4

Smiley

  • Beginner
  • *
  • Posts: 7
  • A beginner
  • VirtueMart Version: VirtueMart 3.0.18
Re: Error Invalid extension update
« Reply #2 on: August 13, 2017, 13:45:14 pm »
Appreciate the clear feedback jenkinhill. :) Will look into doing this asap. Cheers!

Smiley

  • Beginner
  • *
  • Posts: 7
  • A beginner
  • VirtueMart Version: VirtueMart 3.0.18
Re: Error Invalid extension update
« Reply #3 on: August 15, 2017, 05:26:09 am »
Well thankfully I backed up my site before updating from
Virtuemart: 3.0.18 -> VM 3.2.3.9614
Joomla 3.6.2 -> J3.7.4

because my template got overridden! :o So now I've backup and am now back at square 1.  How do I update without destroying the template in use?! Surely this shouldn't be so hard?! Any help again much appreciated.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26090
  • Always on vacation
    • Jenkin Hill Internet
Re: Error Invalid extension update
« Reply #4 on: August 15, 2017, 10:59:12 am »
I guess then that you use a commercial template.  If you use template overrides (the correct way to manage layouts) then these do not get overwritten, only edits made to the core files will be lost.  There is some editing which may be required for commercial templates that use overrides. See  http://forum.virtuemart.net/index.php?topic=135402.0
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.3.9614 on Joomla 3.7.4 PHP 7.0.22

Testing VM3.2.3.9614 on J!3.7.4