Author Topic: Several problems after update  (Read 151 times)

eclipsada

  • Beginner
  • *
  • Posts: 16
Several problems after update
« on: August 11, 2017, 20:35:34 pm »
Joomla 3.6.5
PHP 7.0.1
Virtuemart 3.2.2

Hi,
I just update from virtuemart 3.0.18 to 3.2.2 and several problems appeared...

1. The references of the related products now show up in the shopping cart module and in the cart review page (see attached images).
2. I'm not able to access any virtuemart category or product page (using the link of the products already in the cart list). When I try to open a different page (eg. dog toys category), instead of the correct URL like

/component/virtuemart/caes/trelas

it tries to open

/shopping-cart/caes/trelas

 and shows the same page.

3. If I try to access any category, it adds "?Itemid=166" to the link and remains on the same page. I replaced the sublayouts folder (/components/com_virtuemart/sublayouts) by the one I had before the update and now I'm able to open new pages, although it still adds "?Itemid=166" to the URL.


I'm really annoyed with this.. any ideas?

Thank you.

EDIT: after replacing the sub layouts the 1st problem (related products) was solved.

eclipsada

  • Beginner
  • *
  • Posts: 16
Re: Several problems after update
« Reply #1 on: August 13, 2017, 13:35:16 pm »
As mentioned before, problem 1 was solved after replacing sublayers folder (I still have to find out what was the specific file that made the difference).

Yesterday I realised that turning "URL friendly" off everything worked perfectly. Except having 1km URL, of course.
So, I turned off virtuemart's SEO and then URL friendly on again. It started to show "Assign the component VirtueMart to a menu item" error message. I had to change my homepage to "virtuemart default layout" type in order to turn off that error (it wasn't enough using it in a hidden menu).
Then, I went back to virtuemarts' SEO and turned on categories and product tree... Strict mode and SEF for cart links.
Problem 2 and 3 were solved.

I still don't know exactly why this worked or why it was needed after an update.
Maybe this post helps someone else with similar problems.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26314
  • Always on vacation
    • Jenkin Hill Internet
Re: Several problems after update
« Reply #2 on: August 13, 2017, 13:59:36 pm »
Joomla 3.6.5

If you are using that version then you should update to J3.7.4 as all earlier J! versions are insecure.  https://www.joomla.org/announcements/release-news/5710-joomla-3-7-4-release.html
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8 PHP 7.0.23

Testing VM3.2.5.9653 on J!3.8

eclipsada

  • Beginner
  • *
  • Posts: 16
Re: Several problems after update
« Reply #3 on: August 13, 2017, 17:51:38 pm »
Thank you for your comment.
I was exactly updating my website when I came across these issues. If I update everything at once, then I won't be able to figure out where new problems came from.