Author Topic: Transaction from VM 3.2.2 (Joomla 3.7.1) to authorize.net  (Read 235 times)

mhershey

  • Beginner
  • *
  • Posts: 3
  • A beginner
Transaction from VM 3.2.2 (Joomla 3.7.1) to authorize.net
« on: July 07, 2017, 18:10:36 pm »
I recently found a similar topic on here from 2015 -- but after starting a new storefront a live (non-sandbox) error came up with the following error at the "thank you" page :

Notice : Undefined offset : 50 in ../public_html/plugins/vmpayment/authorizenet/authorizenet.php on line 975
Notice : Undefined offset : 51 in ../public_html/plugins/vmpayment/authorizenet/authorizenet.php on line 976
Notice : Undefined offset : 52 in ../public_html/plugins/vmpayment/authorizenet/authorizenet.php on line 977
Notice : Undefined offset : 53 in ../public_html/plugins/vmpayment/authorizenet/authorizenet.php on line 978
Notice : Undefined offset : 54 in ../public_html/plugins/vmpayment/authorizenet/authorizenet.php on line 979

Any help would be appreciated -- Dont want customers to see this !! Marc

Jörgen

  • Global Moderator
  • Full Member
  • *
  • Posts: 1097
    • Kreativ Fotografi
  • VirtueMart Version: 3.2.5
Re: Transaction from VM 3.2.2 (Joomla 3.7.1) to authorize.net
« Reply #1 on: July 08, 2017, 08:39:59 am »
The error shows a reference to localhost. Do You have some URL pointing to localhost ?

regards

Jörgen @ Kreativ Fotografi
Joomla 3.8.1
Virtuemart 3.2.5
Olympiantheme Hera (customized)

mhershey

  • Beginner
  • *
  • Posts: 3
  • A beginner
Re: Transaction from VM 3.2.2 (Joomla 3.7.1) to authorize.net
« Reply #2 on: July 10, 2017, 14:09:15 pm »
Hello:

Thanks for the reply. My DB settings are still set to localhost as a host. Would that cause the issue with VM / Authorize ?

Marc

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26357
  • Always on vacation
    • Jenkin Hill Internet
Re: Transaction from VM 3.2.2 (Joomla 3.7.1) to authorize.net
« Reply #3 on: July 10, 2017, 15:07:12 pm »
The localhost warning looks like it refers to a certificate mismatch. But I assume that the payment/order process proceeded OK. Maybe you use PHP7.1 ?

These are PHP notices & warnings, the display of which can be suppressed  - http://forum.virtuemart.net/index.php?topic=102555.0

Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8.1 PHP 7.0.23

Testing VM3.2.5 on J!3.8.1