Author Topic: Product detail view disappear after first save of Configuration  (Read 443 times)

theodora

  • Beginner
  • *
  • Posts: 4
Hello,

Please excuse me if there is already similar topic, I could't find something related.

So, I made a successful update from VM 2 to VM3, then J2.5 to J3.5 on a test domain of my site, but then when I make my first change to the shopfront configuration the product details pages become just plain HTML.
I noticed that a virtuemart.cfg file is loaded on a first save and maybe this is the reason, but I cannot figure out what else I have to change to fix the problem.

These are the steps I made (and repeated several times until I noticed that the first shop configuration save might be the reason):
1) Updated to VM 3.0.16, then updated Joomla 2.5 to Joomla 3.51 - everything works fine
2) updated to VM 3.2.2 - OK
3) updated to Joomla 3.72 - OK
4) Then I wanted to make the Shopfront categories display 3 per row, as they are on the live site - after I save this and go to any of the main categories, when I choose a product it's just HTML
If I navigate to a product fron a subcategory then the product is displayed correctly. Before the first configuration save both products from main and subcategories display correctly.

I compared the virtuemart_defaults.cfg-dist and virtuemart.cfg files and the only difference related to templating I noticed is right after "reviews_maximum_comment_length=2000"
in defaults it was:
vmtemplate=0
categorytemplate=0


in virtuemart.cfg it was:
vmtemplate=default
categorytemplate=default


before the first save. But even if I change this the issue remains.

Could someone please help me with this case?
Thanks in advance!

URL : http://stmaximus.tonershop-bg.com
product detail page when opened from main category - http://stmaximus.tonershop-bg.com/%D0%BF%D1%80%D0%B0%D0%B2%D0%BE%D1%81%D0%BB%D0%B0%D0%B2%D0%BD%D0%B0-%D0%BA%D0%BD%D0%B8%D0%B6%D0%B0%D1%80%D0%BD%D0%B8%D1%86%D0%B0/%D0%B4%D1%83%D1%88%D0%B5%D0%BF%D0%BE%D0%BB%D0%B5%D0%B7%D0%BD%D0%B8-%D1%87%D0%B5%D1%82%D0%B8%D0%B2%D0%B0/the-montreal-myrrh-streaming-icon-and-brother-joseph-detail

same product opened from a subcategory - http://stmaximus.tonershop-bg.com/%D0%B6%D0%B8%D0%B7%D0%BD%D0%B5%D0%BE%D0%BF%D0%B8%D1%81%D0%B0%D0%BD%D0%B8%D1%8F/the-montreal-myrrh-streaming-icon-and-brother-joseph-detail

The leftside menus are displaying the subcategories.
The site is in bulgarian (if someone would use google translate.

EDIT:
Quote
3) updated to Joomla 3.72 - OK
- this step I made but then I repeated the whole Joomla 2.5 to 3 update process while looking for the problem, and currently I left Joomla 3.5.1 just in case (but with J3.7.2 it worked fine also before saving the VM configuration)

Current site details:
Joomla 3.5.1
VM 3.2.2
PHP 5.6.29
Gantry 4 framework + Gantry template
I don't use any template overrides.In VM configuratiI haven't change anything else (besides N of categories per row for shopfront).
Joomla! 3.7.2 | VM 3.2.2

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26357
  • Always on vacation
    • Jenkin Hill Internet
Re: Product detail view disappear after first save of Configuration
« Reply #1 on: June 28, 2017, 17:30:13 pm »
I edited your second demo link - you has set it as email rather than url.

Suggest you test with SEF off to see if that fixes it, and also try with the Protostar template.
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8.1 PHP 7.0.23

Testing VM3.2.5 on J!3.8.1

theodora

  • Beginner
  • *
  • Posts: 4
Re: Product detail view disappear after first save of Configuration
« Reply #2 on: June 28, 2017, 18:45:09 pm »
Thanks for the edit and for your reply.
I tried with SEF URLs turned off but no effect.
With Protostar it works (both SEF on and off).
But then how was it working with Gantry template before I made the first change to the VM configuration? What does it load different from the initial VM setup?

Joomla! 3.7.2 | VM 3.2.2

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26357
  • Always on vacation
    • Jenkin Hill Internet
Re: Product detail view disappear after first save of Configuration
« Reply #3 on: June 28, 2017, 23:28:16 pm »
I dont know and heva never used gantry - I use templates without the overhead of frameworks. But obviously the template is causing your problem, maybe check console for JavaScript errors?
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8.1 PHP 7.0.23

Testing VM3.2.5 on J!3.8.1

theodora

  • Beginner
  • *
  • Posts: 4
Re: Product detail view disappear after first save of Configuration
« Reply #4 on: June 29, 2017, 11:28:16 am »
It gives this error - "Failed to load resource: the server responded with a status of 500 (Internal Server Error)"

I understand that since it's working with the other template it may be template related, but the same Gantry template displays also correctly before I make the first change on the VM configuration and hit "Save" (then it says that it loaded virtuemart.cfg file).
If I make changes to VM configuration from PhpMyadmin to skip the "save" part, it would also work well, but I want to be able to make such changes from Joomla backend.
If the template fails to deliver some resource after the VM configuration is saved for the first time, then maybe this is a combination of template related + vm related issue?

Maybe I will try to setup the site again and look for errors before I make the first configuration changes to VM.
Joomla! 3.7.2 | VM 3.2.2

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26357
  • Always on vacation
    • Jenkin Hill Internet
Re: Product detail view disappear after first save of Configuration
« Reply #5 on: June 29, 2017, 11:55:06 am »
Try the fatal errorreporting plugin - http://forum.virtuemart.net/index.php?topic=117042.msg470068#msg470068   that should help identify the exact cause of the 500.
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8.1 PHP 7.0.23

Testing VM3.2.5 on J!3.8.1

theodora

  • Beginner
  • *
  • Posts: 4
Re: Product detail view disappear after first save of Configuration
« Reply #6 on: June 30, 2017, 12:52:45 pm »
Hi, thanks for this, very usefull plugin.
It gave me several different errors from opening just one page

Quote
RuposTel.com plg_system_fatal_catcher plugin detected a problem with your site.
Your site caused a blank screen upon a visit of this URL:

http://stmaximus.tonershop-bg.com/index.php?option=com_virtuemart&view=productdetails&virtuemart_product_id=34&virtuemart_category_id=147

Error message data:
1 Call to a member function displayMediaThumb() on null in file: /home/toners/public_html/stmaximus/components/com_virtuemart/views/productdetails/tmpl/default_showcategory.php line: 72

timestamp: 2017-06-30T10:38:48+00:00

Quote
RuposTel.com plg_system_fatal_catcher plugin detected a problem with your site.
Your site caused a blank screen upon a visit of this URL:

http://stmaximus.tonershop-bg.com/index.php?option=com_virtuemart&view=productdetails&virtuemart_product_id=34&virtuemart_category_id=147

Error message data:
8 Undefined property: VirtueMartViewProductdetails::$askquestion_url in file: /home/toners/public_html/stmaximus/templates/gantry/html/com_virtuemart/productdetails/default.php line: 309

timestamp: 2017-06-30T10:38:48+00:00

For the second one - I renamed the productdetails folder (I forgot I had these files from the J2.5 setup) and now the product detail page looks better (no plain HTML), but still strange. And the left menu with the VM categories is still disapearing.

Quote
RuposTel.com plg_system_fatal_catcher plugin detected a problem with your site.
Your site caused a blank screen upon a visit of this URL:

http://stmaximus.tonershop-bg.com/index.php?option=com_virtuemart&view=category&virtuemart_category_id=147

Error message data:
2048 Declaration of plgVMPaymentSystempay::emptyCart() should be compatible with vmPSPlugin::emptyCart($session_id = NULL, $order_number = NULL) in file: /home/toners/public_html/stmaximus/plugins/vmpayment/systempay/systempay.php line: 833

I'll look more into what files I have left from the old version.


Joomla! 3.7.2 | VM 3.2.2

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26357
  • Always on vacation
    • Jenkin Hill Internet
Re: Product detail view disappear after first save of Configuration
« Reply #7 on: June 30, 2017, 13:08:27 pm »
Quote
Call to a member function displayMediaThumb() on null.....

This answers that:  http://forum.virtuemart.net/index.php?topic=137723.msg482470#msg482470  (and there are several other threads about this error related to out of date template overrides.
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8.1 PHP 7.0.23

Testing VM3.2.5 on J!3.8.1