Author Topic: Desperate need in help...  (Read 712 times)

dariuszelvys

  • Beginner
  • *
  • Posts: 8
  • A beginner
Desperate need in help...
« on: June 13, 2017, 23:11:03 pm »
Hi guys, i'm in desperate need of a help.
After migrating and updating virtuemart to 3.2.3 , and joomla to 3.7.2 and shaper helix3 template i noticed a strange thing...
Using PHP 7.0 btw.

http://www.agropartsbaltija.lt
If i use firefox browser, everything works, i can add products to cart, delete them, checkout (VM one page module).
If i use chrome - i get that stuck screen and it doesnt go away. It comes, when i try to select payment, of change the quantity in cart. It used to work, but i can't say which is the last version it worked.

Tried to play with jquery easy module - didn't help.
Any help would be greatly appreciated.
It's not related to template, cause the same thing happens with other templates.

dariuszelvys

  • Beginner
  • *
  • Posts: 8
  • A beginner
Re: Desperate need in help...
« Reply #1 on: June 13, 2017, 23:17:21 pm »
and one more thing. I can't even add products to cart in chrome if  Display modal popup upon 'Add to cart'  is selected in config.

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9372
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Desperate need in help...
« Reply #2 on: June 14, 2017, 10:19:32 am »
Looks like Javascript problems, but when I enter your page I get "Call to a member function NewColorizeImage() on null" and we do not use this function. Seems to be some overrides.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

dariuszelvys

  • Beginner
  • *
  • Posts: 8
  • A beginner
Re: Desperate need in help...
« Reply #3 on: June 14, 2017, 12:12:34 pm »
Now it's working, could you please help me. I think i've tried everything i could...

dariuszelvys

  • Beginner
  • *
  • Posts: 8
  • A beginner
Re: Desperate need in help...
« Reply #4 on: June 14, 2017, 14:58:24 pm »
Further story: Restored from backup site, that has  3.7.0 , and other parts fully updated. And to my suprise, it works. Almost everything, just fancybox fails, other parts work perfect. Really afraid to push update button :D

dariuszelvys

  • Beginner
  • *
  • Posts: 8
  • A beginner
Re: Desperate need in help...
« Reply #5 on: June 14, 2017, 15:24:32 pm »
And of course, our 3rd party payment system works with fancybox popup too...
Damn.. Could somebody please help

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 7609
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.2
Re: Desperate need in help...
« Reply #6 on: June 14, 2017, 15:47:59 pm »
the FIRST thing to do is clone the site so u have a safe place to work with it!!!
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

dariuszelvys

  • Beginner
  • *
  • Posts: 8
  • A beginner
Re: Desperate need in help...
« Reply #7 on: June 15, 2017, 09:15:00 am »
Fully updated site :) And guest what. FancyBox is not working...  Could anybody please help me?

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 9372
  • VM3.2 Cached and Optimized
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: Desperate need in help...
« Reply #8 on: June 15, 2017, 10:00:43 am »
Disable the override for productdetails and test then.
I should fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

dariuszelvys

  • Beginner
  • *
  • Posts: 8
  • A beginner
Re: Desperate need in help...
« Reply #9 on: June 15, 2017, 11:25:54 am »
Template i'm using doesn't have any ovverides for virtuemart

dariuszelvys

  • Beginner
  • *
  • Posts: 8
  • A beginner
Re: Desperate need in help...
« Reply #10 on: June 15, 2017, 11:46:55 am »
Strange things happening. Updated to com_virtuemart.3.2.3_extract_first.9579
And everything works now.

layman

  • Beginner
  • *
  • Posts: 2
  • VirtueMart Version: 3.2.4
Re: Desperate need in help...
« Reply #11 on: October 10, 2017, 12:40:10 pm »
A similar situation
Made a copy of Joomla 3.8.1, vm 3.2.4, php 5.6.31.
Unpacked on another server with PHP 7.1.9 the admin panel works. shows up on the website error (error 0 Call to a member function NewColorizeImage() on null)  >:(
Changed PHP 5.6.31 - site works :D. Went back to PHP 7.1.9 freewheeling on top of the vm 3.2.4 - all works  :D

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26358
  • Always on vacation
    • Jenkin Hill Internet
Re: Desperate need in help...
« Reply #12 on: October 10, 2017, 13:37:32 pm »
NewColorizeImage is not a default VM function so the error must be from some 3rd party plugin or other extension.
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8.1 PHP 7.0.23

Testing VM3.2.5 on J!3.8.1