Author Topic: Component Missing  (Read 1295 times)


  • Beginner
  • *
  • Posts: 4
Component Missing
« on: May 05, 2017, 21:50:52 pm »
Hi all

I have recently simply had VM disappear from my backend! I'm running J 3.7.0 and a recent VM version (as I can't see it I can't tell you which, exactly) and the only thing I've changed today was activating the Content Statistics Backend Modules.

VM is still "there" - as Content Statistics is pulling data, AND my store is still there, but it's missing from my backend.

I have tried the Xmap option but I do not have the plugin installed.
I have tried the PHPMYADMIN option but failed to find the tables which were mentioned, or the fields mentioned.


GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 9748
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.6.8
Re: Component Missing
« Reply #1 on: May 05, 2017, 21:56:08 pm »
it is only simple menus

either enable the admin vmadmin module, replace your com_virtuemart menus in the #__menus table or even install  -- its a nice 3rd party Joomla/VM admin template that incl. extra direct menus

u can always reach VM by
GJC Web Design
VirtueMart and Joomla Developers - php developers
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
Contact for any VirtueMart or Joomla development & customisation


  • Beginner
  • *
  • Posts: 4
Re: Component Missing
« Reply #2 on: May 05, 2017, 22:14:22 pm »


  • Beginner
  • *
  • Posts: 21
Re: Component Missing
« Reply #3 on: May 10, 2017, 19:03:25 pm »
Hi there

I have the 2 situations....

Menu desapear from Components menu and on save categories if  i add a new, then go to products, first deson´t appear on filter search, now i unistall JCE and i can see them, but on save product i delete old categorie, input new save and go back to old one.

If i add a 2º one, appear the 2, i click the product only appear one.

I cann´t do anything like this is all bugged

I even try it directly throw PHPmyadmin, problems stays, I even activade cache, problem stays....

This is really strange

I try chrome, safari, IE nothing... keeps doing the same

Hope it helps