Author Topic: [SOLVED] Wrong language in vm3 menu  (Read 1796 times)

Geppux

  • Jr. Member
  • **
  • Posts: 163
[SOLVED] Wrong language in vm3 menu
« on: April 26, 2017, 17:44:47 pm »
VM 3.2.1 - J 3.7.0

I have a small problem, probably is something stupid, but I searched without success...
I have the backend all in italian but the lateral menu of virtuemart is in english!
I installed the italian files but no succes... what can it be?

Thank you.

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3167
  • using Piwik instead of Google Analytics
Re: Wrong language in vm3 menu
« Reply #1 on: April 26, 2017, 23:03:55 pm »
Works in my case (with German language files). Perhaps install the Italian language pack available at http://virtuemart.net/community/translations again.
Also you could enable the Joomla 'Debug Language' in the configuration and check if the file ...\administrator\language\it-IT\it-IT.com_virtuemart.ini is loaded.

Note that some users with multilanguage websites reported language issues after updating to Joomla 3.7.0. Some issues are already listed in the Joomla tracker.
However, some issues may be due to a change in how language ini files are parsed by Joomla. Might take a few days until the component developers come up with solutions addressing that change.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

Geppux

  • Jr. Member
  • **
  • Posts: 163
Re: Wrong language in vm3 menu
« Reply #2 on: April 27, 2017, 10:20:56 am »
Thank you JJK for the answer.
I already reloaded the language files several times but is always the same. I don't think is an issue regarding multilingual sites because I have the same on 2 sites, one multilingual and the other not. I'll wait the developers find what's wrong, it's not a problem to have it in english... all the other things seems to work properly.

tutek

  • Beginner
  • *
  • Posts: 2
Re: Wrong language in vm3 menu
« Reply #3 on: April 27, 2017, 13:24:14 pm »
Hello,
I have the same problem.
Joomla: 3.7.0 VirtueMart: 3.2.1

I have installed Polish, but the system shows that it does not load.

What could be the reason?

Jörgen

  • Global Moderator
  • Full Member
  • *
  • Posts: 1022
    • Kreativ Fotografi
  • VirtueMart Version: 3.0.19.9
Re: Wrong language in vm3 menu
« Reply #4 on: April 27, 2017, 14:17:05 pm »
Hello

My guess would be Joomla 3.7.0. There are appearantly some issues reagarding the loading of languages. If the fixes have to be done in Joomla or the extensions is hard to tell right now.

regards

Jörgen @ Kreativ Fotografi
Joomla 3.6.5
Virtuemart 3.0.19.9
Olympiantheme Hera (customized)

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3167
  • using Piwik instead of Google Analytics
Re: Wrong language in vm3 menu
« Reply #5 on: April 27, 2017, 21:04:21 pm »
Hello,
I have the same problem.
Joomla: 3.7.0 VirtueMart: 3.2.1

I have installed Polish, but the system shows that it does not load.

What could be the reason?

Ok - I checked this one. The problem with this one and probably also some other languages is that some translators used "_QQ_", which is an old Joomla method to escape " (double quotes)  instead of the single quotes ' in the en-GB source file strings, which Transifex (currently) translates into "_QQ_"_QQ_"_QQ_" and Joomla 3.7.0 doesn't tolerate that anymore. (There are still hundreds of "_QQ_ " in the Joomla language files, although using this is deprecated since a long time already).

In order to solve this issue in VM translations, turn on 'Debug Language' in Joomla configuration, then open your VM pages and look for 'Parsing Errors in Language Files' at the bottom of the view. If there are any, the 'Parsing Errors' tab will list the language file(s) and the lines which fail to parse. Open these files in an Editor like Notepad or Notepad++ (Do not use a Word processor like MS Word!), scroll down to the lines which failed to parse and replace any  "_QQ_"_QQ_"_QQ_" with ' (single quote). Don't forget to save the file.

I'll send a message to Translators on Transifex, that they should look through their translations and replace any occurance of  "_QQ_".
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

CE WebDesign München

  • Jr. Member
  • **
  • Posts: 112
  • CE WebDesign München
    • CE WebDesign München
Re: Wrong language in vm3 menu
« Reply #6 on: April 29, 2017, 10:28:15 am »
if you don't want single quotes ( ' ),
you can escape double quotes like this: \"

https://github.com/joomla/joomla-cms/issues/13421#issue-198146295
CE WebDesign München: https://ce-webdesign.de | Websites, eCommerce WebShops | Responsive Design | SEO

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3167
  • using Piwik instead of Google Analytics
Re: Wrong language in vm3 menu
« Reply #7 on: April 29, 2017, 11:40:17 am »
if you don't want single quotes ( ' ),
you can escape double quotes like this: \"

No! If you escape double quotes in source language files like this, the translation platforms like Transifex and Crowdin. which are used by many extension translators (including VirtueMart translators), will create garbage in the downloadable translations, that results into parsing errors. Either use single quotes or an html entity for double quotes.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

CE WebDesign München

  • Jr. Member
  • **
  • Posts: 112
  • CE WebDesign München
    • CE WebDesign München
Re: Wrong language in vm3 menu
« Reply #8 on: April 29, 2017, 12:14:54 pm »
OMG! Thanks for pointig out!
But for language overrides like in joomla/language/overrides/de-DE.override.ini it is ok to replace all _QQ_ with /"   ?
CE WebDesign München: https://ce-webdesign.de | Websites, eCommerce WebShops | Responsive Design | SEO

Geppux

  • Jr. Member
  • **
  • Posts: 163
Re: Wrong language in vm3 menu
« Reply #9 on: April 29, 2017, 12:18:02 pm »
tI turned on the language debug on my site and in the enclosed image are the results... It seems There are no errors in the language files but  it seems there are not the translations, right?

Geppux

  • Jr. Member
  • **
  • Posts: 163
Re: Wrong language in vm3 menu
« Reply #10 on: April 29, 2017, 12:57:27 pm »
For the italian version the problem has been solved... now the language files are written in the correct way and installing the new version solved the problem.

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3167
  • using Piwik instead of Google Analytics
Re: [SOLVED] Wrong language in vm3 menu
« Reply #11 on: April 29, 2017, 14:16:19 pm »
OMG! Thanks for pointig out!
But for language overrides like in joomla/language/overrides/de-DE.override.ini it is ok to replace all _QQ_ with /"   ?

If you edit your language overrides in Joomla administration 'Extensions' > 'Language(s)' > 'Overrides', you can enter " directly. Otherwise it is more safe to use the html entity 
Code: [Select]
"
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

tutek

  • Beginner
  • *
  • Posts: 2
Re: [SOLVED] Wrong language in vm3 menu
« Reply #12 on: May 05, 2017, 12:20:18 pm »
Hello

Helped me to remove some lines from the translation where they were "_QQ _" _ QQ _ "_ QQ_".

The language file was correctly loaded.

cmvrgr

  • Beginner
  • *
  • Posts: 8
  • A beginner
Re: [SOLVED] Wrong language in vm3 menu
« Reply #13 on: May 05, 2017, 14:45:15 pm »
I have the exact same problem with Greek language. Can someone write a step by step guide to fix the problem ?

Thanks

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3167
  • using Piwik instead of Google Analytics
Re: [SOLVED] Wrong language in vm3 menu
« Reply #14 on: May 05, 2017, 23:35:03 pm »
@cmvrgr
Meanwhile the triple "_QQ_" should be eliminated from the automatically generated language packs. Please download and install the current Greek translation files from here and check if that solves your problem: http://virtuemart.net/community/translations
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations