Author Topic: Need help with multi language articles/categories that do not show up  (Read 348 times)

accessvirus

  • Beginner
  • *
  • Posts: 28
    • Creative Director
  • Skype Name: alexander-van-aken
I started of at VM 3.0.18. When I was playing around with multi language in VM I noticed that as soon as I set the dutch language as the second language, the product and categories where empty. So I removed english to see if that helped and solo go dutch. It didn't. Then I changed it back and did some toggling again. At some point there was aVM notice box at the top after doing a "save" that notified me of making some language specific VM tables, but it didn't solve the problem.

Now when I setup multilanguage in Joomla and assign all the neccessary things, it seems that the product categories inculding the products are all still gone. Something I didn't expect due to the above which made me think this multi language joomla setup would fix it. The only option I have is to put it all back to English but I need to go dutch primarily. It didn't make any difference to update to VM 3.2.1. So I start adding all categories manually due to the probability I wasn't capable of fixing this myself, but then I stopped as of this moment at the first category because it might do more harm in the end due to duplicate alias when I found a support tip from any of you guys here. I wonder how to get back at least the categories and to do the repair. The products where demo products anyway. My template is Joomlart's megastore. Currently not supported above 3.0.18. I love the template design but I hate their late updated templates.
Jack of all trades with a specialization in Branding, Graphic- & sound design

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3113
  • using Piwik instead of Google Analytics
Re: Need help with multi language articles/categories that do not show up
« Reply #1 on: April 17, 2017, 23:51:22 pm »
In your case I would suggest to do your language configuration using the Protostar or Beez5 template first. Also please check in your database if the product and category tables with the en_gb and nl_nl language suffixes exist and if your dutch product descriptions are stored in the dutch product table. I assume you did install the Dutch language packs for VirtueMart and have Dutch added in the VM language settings.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

accessvirus

  • Beginner
  • *
  • Posts: 28
    • Creative Director
  • Skype Name: alexander-van-aken
Re: Need help with multi language articles/categories that do not show up
« Reply #2 on: April 20, 2017, 11:01:05 am »
The tables are a mess. The tables suffixes exist, hjowever the records inside the virtuemart_products_nl_nl table is completely empty where as the en_gb and the non suffix versions are not equal in content.

To start all over, is it safe to delete all records manually from phpmyadmin for both language suffixes as for the non suffixes? Or is there a button @ the tools that does that?
Jack of all trades with a specialization in Branding, Graphic- & sound design

jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3113
  • using Piwik instead of Google Analytics
Re: Need help with multi language articles/categories that do not show up
« Reply #3 on: April 20, 2017, 22:57:12 pm »
Export the database with phpmyadmin first with the 'Custom - display all possible options' and 'Add DROP TABLE / VIEW / PROCEDURE / FUNCTION / EVENT statement' checked (you can keep all other default settings). That way you can always import it into an empty database again if required.
 
You could try the 'Install or if necessary update tables' button in the VM tools view. But I suppose it won't heal all database problems.

Other options depend on how much content you already added. If its a lot, it would make sense to try save it. If you didn't add much yet, it might be faster to start from scratch again.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

accessvirus

  • Beginner
  • *
  • Posts: 28
    • Creative Director
  • Skype Name: alexander-van-aken
Re: Need help with multi language articles/categories that do not show up
« Reply #4 on: April 26, 2017, 15:30:10 pm »
Thanks. They finally came with an update. So I am going to start fresh. Theoretically, could I, for each table that has suffix for a language tag, safely delete the content and refresh the backend to start adding new content or does this mixup some other tables? Just to get my understanding. There are non suffix tables and for each country a suffix. When working with 1 language. Does a suffix exist always together with the default one with no suffix or do at least 2 get created uppon multi language setup? So first do the default joomla mulilanguage setup and then after that is done do it in VM right? I think I started adding a language in VM and forgot to do it in joomla. Maybe with the old version it there made my problem occure.
Jack of all trades with a specialization in Branding, Graphic- & sound design