Author Topic: Posible Bug with VirtueMart 3.2.1 when installing our payment plugin  (Read 194 times)

ndaumalle

  • Beginner
  • *
  • Posts: 8
  • A beginner
Hello,
We developed a payment plugin for virtuemart and we successfully tested it until the version 3.0.1.4 of virtuemart in our test server. So we wanted to test with virtuemart 3.2.1 now.
we installed joomla 3.6.5 with virtuemart 3.2.1 using the full installer "Full installer includes Joomla 3.6.5 with VirtueMart 3.2 installed" from https://virtuemart.net/download without issues.

But then we installed our payment plugin from zip package, it didn't work and we can see a fatal error in our log files. We trace the error in the vmplugin.php file at line 69 "$this->loadJLangThis($filename); //TODO remove this is not allowed here, else systemplugins derived from vmPlugin throw errors on a multilanguage pages".

Is it possible that this function has not been removed by accident (as marked as TODO in the line's comment)?

We can trace further the error and see that the problem is in vmplugin.php in the function loadJLang($fname,$type,$name) at line 108 $tag = vmLanguage::$currLangTag;
where $tag appears to be empty.

We would really appreciate any help.
Girosolution.