Author Topic: delayed translation  (Read 480 times)

mr.fifteen

  • Beginner
  • *
  • Posts: 5
  • A beginner
delayed translation
« on: April 13, 2017, 17:50:20 pm »
Hello
I have a problem with virtuemart in a multilingual site. all virtuemart components are not translated immediately when I click on the British flag but only after another click (or after reloading the page).
also if I click on the flag while I'm on a product page I am sent back to the main page of the products and not on the one where I was.
is this normal?

this is my site www.serrature.net
i have the last version on Joomla and Virtuemart.


jjk

  • Global Moderator
  • Sr. Member
  • *
  • Posts: 3184
  • using Piwik instead of Google Analytics
Re: delayed translation
« Reply #1 on: April 13, 2017, 23:10:22 pm »
Sounds like this issue: http://forum.virtuemart.net/index.php?topic=136543.0
On my site I have to disable the Piwik plugin for VirtueMart to make it work with the now deprecated (but still usable) 'VM Frontpage' active. Haven't tried yet to 'simulate' the VM frontpage with the new VM category settings.
Non-English Shops: Are your language files up to date?
http://virtuemart.net/community/translations

mr.fifteen

  • Beginner
  • *
  • Posts: 5
  • A beginner
Re: delayed translation
« Reply #2 on: May 01, 2017, 17:47:53 pm »
Thanks (with a lot of delay) for your answer.
I solved this problem by updating virtuemart to version 3.2.1.
The problem remains only on the virtuemart homepage. I've already tested that this is not a problem with the template.
Does anyone know where I can edit the files for that page? In addition to the template on the page (com_virtuemart / views / virtuemart) that seems to have no problems

Thanks